BNO weird readings and iPhone wifi problem

Is there a way to allow the tablet to give aog more proccessing power, and ram. I have a i5 4 generation and 4gb of ram and aog fells a little laggy, mostly the bno reading. Using the new 5.7.1 version, teensy all in one, UDP.

Can’t conjure RAM out of nowhere, your best bet is to stop any un-needed services and that way there’s more resource for AOG.

You should try and upgrade memory if that’s an option.

Cpu is at 3%, ram is 1,5GB/4GB, any unnessesary apps have been stop. I used winaero teeaker to disable windows update and Cortana. Autosteer works perfectly at 4kmh, don’t know about faster speeds, will test in the future. Im used to the yellow roll value to update faster when everything was USB.

Maybe i messed up the teensy flashing. There are options for speed, etc. What are the recommended values.

Set the laptop to be Power Options, Performance mode. Maybe it’s slowing down thinking it’s got an easy life…

I think i did that already, will double check. Thanks. Also the tablet want connect to my iPhone it just says cant connect to this network. Tried everything i could possible think off. Network reset, changed name and password, updated the device etc

2.4ghz / 5ghz mismatch perhaps? Can you share a 2.4ghz net from your phone?

1 Like

I don’t know how to do that, i usually just go into settings->personal hotspot->on and thats it. It works on my other tablet. How to change between 2,4Ghz and 5Ghz

Download Winaero tweaker and disable Windows telemetry. This can help speed up an underpowered PC

Maybe it has been asked before, can AOG be used with win 10 Lite?

It can. I am using it with win 10 lite just need to install a few drivers if you are using the USB method.

1 Like

I did that already, its not a underpowered pc, my last setup was with a old tablet that had a celeron processor and it worked perfectly, only it was usb.

What are the recommended settings for teensy flashing. Should i use this or change CPU Speed etc?

You can lower speed to 450 to keep the temperature down, but apart from that it’s all good. It won’t affect the speed it supplies to AOG or anything.

Just a remember:
if you feel it is laggy be sure you use fields created on the field or directly with a .klm file.

if you create a field in simulator mode then use it in real it can be very laggy because you could be way to far away from the field base point.

This is the number 1 cause of laggy AOG.

if bno seams laggy you try “roll filter” near or at 0

Fields are created in version 5.5 by driving around in real life. Roll filter is at 0. Just tested it in field. Its laggy, noticed it when i was turning. I will try installing dotNet, don’t why else it would lag.

You already have the required dotnet libraries, AGO wouldn’t run without them.

Yes that was the wifi problem, updated the driver and now it connects. For anyone having the same problem here is a YouTube video i followed Surface Pro 3 4 "Unable to Connect to this Network" quick fix for 5Ghz AC networks WIFI error - YouTube

I think the bno is slow to react. The roll zero and roll direction are set right, traktor leaning right is positive, and roll zero was set on a concreate surface.

Now at slow speeds it shows correctly but faster the roll is weird. It shows negative when tractor is right, and sometimes it shows positive when tractor is right. It looks like lag

I’m yet to test this on a very old laptop with 2GB of ram: Tiny11 makes Windows 11 run on low-end unsupported systems - Pureinfotech

The roll didnt lag, i placed the imu like on the photo and that was the problem. Updated to 5.7.2 and swapped it in the settings, problem solved. I feel so dumb right now but we learn on our mistakes.