GPS works then stops

I have my Ardusimple Board hooked up and getting good signal from plenty of satellites. The lat/long updates and calculates my speed in the tractor for 30 seconds to a minutes then everything stops. As far as I know so far, I’m getting too much info from the GPS unit. I’m getting more than just the GGA and VTG, but I have the aortner 8hz configuration loaded onto the board. Idk what my issue is, any help is greatly appreciated.

Maybe the config you got did not turn off some of the sentences.
We got U-center and the user manual from u-blox to set ours up. it was long ago so I cannot remember the specifics to explain the steps, maybe someone more knowledgeable will chime in.

Thanks, I have looked for a tutorial (I haven’t been thorough) on how to do it, so if someone could point me in the right direction I’m sure I could figure it out. U-center is still pretty confusing for me.

I haven’t tried it in the field, but I think I got it figured out. If anyone has the same issues go to:

In U-Center, open the text console (it shows how in the above link) to see what the fp9 is outputting. Then go to the configuration view and go to Messages (MSG). In the drop-down box, select each type of NMEA sentence and uncheck the I2C, UART1, UART2, USB, and SPI and click send. Do not disable the GGA or VTG sentences. As you uncheck and send each one, you should see on the text console that the unchecked messages stop being reported. When you are done, the text console should only be showing GGA and VTG sentences. I hope this helps.


Are you sure you loaded Andreas his config? Had the same issue and after loading this everything was right

… and saved it to non volatile memory!

It’s actually pretty easy with the sparkfun ublox arduino library to set up the board the way you need it at run time when the board powers up. I believe the UARTs by default accept ublox. That way one could drop a new board in and it would just work. I think that would be worth having in the sketch. Dealing with baud rates is a bit tricky though.

This is where i2c is nice but the ardusimple boards don’t expose that interface, sadly.

Update: I tried it out on the tractor today and the same issue, maybe 60 seconds of working then it just stops updating and returns the same lat/long and altitude perpetually. I tried reverting to the original rover settings/config from UBlox with the Gps sentences filtered out and it finally worked. So I’m going to roll with that for now.

It’s not surveying in as a base is it? Just a thought.

Might be a ridiculous suggestion but I’ve found u-centre a bit of a minefield until you get what’s going on.

It’s not surveying in as a base is it? Just a thought.

There is also a possibility
please confirm
UBX-CFG-TMODE3 0-disable

1 Like