Nano not recognized

Hello, i had everything working nicely and then i beleive i had a voltage spike cook everything. So now ive replaced my knockoff nano with the official one and i cant get my tablet to recognize it, it just says “usb serial port” and im not seeing my WAS now. A secondary problem i also replaced my ardusimple rtk2b board and im not getting rtk signal either. Im still using usb connections. Thank you.

Also, if i plug this tablet back into another machine that worked fine it no longer sees the WAS there either so i must have done something wrong in the software.

Does it work if you install the CH340 driver for the nano?

No it doesnt, i installed that and tried it here, i also went to another machine that stilll has the knock off nano in it and tried it there and it didnt work there either. And that machine worked fine when i parked it. So ive messed something up.

Im seeing now its telling me the steer module is not conected, i am getting a tilt reading from the imu but nothing else

I uploaded the autosteer sketch and the steer module shows connected but no WAS which was working fine before i had this wreck.

Also, im not sure if its a glitch or a newer version but im not seeing the “AgDiag” or “UDP” boxes in the AgIO setting box

Are you working with a breadboard and DuPont wires, or a PCB?

Sounds a bit like the 12V circuit may not be getting power. What colour is the icon in the bottom right corner of the AOG screen; red, yellow or green?

I have pcb version 2, the icon is red and turns yellow when i hit the foot switch and the motor will spin in test mode but the WAS doesnt respond so it doesnt stop spinning. I tried changing out the ads1115 but it made not difference. Its funny i dont get a WAS reading even when i switch to a different unit i know was working. Maybe unrelated but im not getting rtk with my rtk2b receiver either.

I do have 5 volts at the board where the WAS connects, im not sure how to check the rest of the sensor, im seing 3volts on the “high” connection currently.

You have powered thé pcb with 12v ? Relay make sound when u use power Switch ?

Yes it has an external 12 volt supply and the relay does click but I don’t understand things enough to know if there is a fault somewhere else on the board. I can measure 5 volts at the WAS. I don’t know if this tells you anything but if I have the tractor running the WAS will ready 0.5 degrees and if I shut it off and leave the key on it measures 35 degrees. Thank you again.

Are you using a Cytron driver? If so, does this board have power? Does it spin the motor from the manual buttons on the board?

Yes that all works fine, it will even spin the motor itself when i hit the little tractor icon to record a circle and set the ackerman etc, which i cant do until i get the WAS reading

Is it possible im doing something dumb with uploading the sketch and its not seeing the WAS. Im pretty green with all this stuff.

Quick update, looks like i had 2 wires crossed on my WAS, why it quit working in other machines i dont know but i re-uploaded the sketch and everything is working in all the machines now so thank you for your time…just have to figure out my rtk now but i know its in my rover board for sure now, its working on other rovers.

Someone once called me complaining that a PCB I had provided was not working. I knew it was good as I had removed it from a working machine, so days of head banging later it turned out he had removed and then rewired the IMU, getting two wires back to front which caused the 12v circuit to fail, exactly as you report.

Sorry, I just didn’t think of this, but it’s one to bear in mind.

Pleased you got it fixed.

Thank you, ya i can really agravate myself lol.