Rtcm messages f9p issue

i am having an issue with F9P messages.

 I am using 1005,1077,1087 and 1230.  this is the package of message Ublox is sending out.



I am having a RTK Signal dropping from time to time, took me months to figure out where the issue was, I think that messsage 1087 delaying  is the problem.  As long as I know MSM messages should be ramdomly in the same package,   SO as I am using 1077 and 1087 MSM7 they should get to the rover together in the same package, which is not.



  first up to 20 packages messages come smoth and  Ramdomly all 4 messages in the package ok,  here I get fixed position then 1005,1077 and 1230 come up at same time and  message 1087 shows up delaying like 1 second it persist up to 20 package messages, which I believe is causing signal dropping.

So my questions are:

   Is there a way to set f9p to send out message Package without delaying any of the RTCM messages?

 would it work if I set messages 1077+1087+1008 at 1 sec and all the rest at 10, 20 or 30 seconds?



  I have changed the f9p also, we have 3 f9p modules, all of them is having same issue.

Yes you can set the rate on individual messages. There’s two settings that control the speed of the messages. First under RATE you can set the minimal time period between messages. By default it’s set to 1000 ms, which means you can get 1 Hz out of it. If you want faster like 5hz, you’d need to set that to 200 ms. Then go to MSG and select the RTCM messages individually and set the number time periods between messages, and this applies to all messages. So if you had RATES time period set to 1000 ms, then if you go to MSG and bring up a particular RTCM message (or NMEA message type), and set the number to 1, it will be every 1*1000 ms. If you set it to 10, it will be every 10 * 1000 ms or 10 seconds. so you can set the 1077,1087, etc to every 1 second, and the rest you can set to whatever you want. 1008 actually only needs to be every 30 seconds or so.