Slow display update

A few days ago AOG had me going in circles. I had to delete appdata, so I had to redo USB connection info and NTRIP. Now the display is very slow to update - it really shows up after a uturn, not an auto one, that would be a real disaster with the slow update. GPS is set to 38400 baud. I can’t find any other setting that might be slowing this up.

I’m running V5.4. Any ideas? I’d tell ya what HZ it’s running but I don’t know where to find that.

Tap on the speedometer square in the top right corner underneath the correction timer, in AOG. That will open up the stats pop up.

When it pops up look at the frame number above the gps hz, what is that number?

Try running at a faster baud, 57600 baud. Whatever the fastest speed it will run at.

I had a similar problem, turned out I hadn’t remembered to shut off all the extra NMEA sentences from my Ardusimple.

1 Like

@Bwatts so you think that the problem lies with the f9 and not necessarily AOG?

In AgIO look at gps data, what messages are arriving?

@Ray_Jorgensen It’s certainly worth looking at. Mine would get further and further behind which also lead to terrible steering. I was confused because it was a unit I had already ran for a couple of years with no problems and then first use this spring it was terrible. Only difference was that I had bought a new F9p so I didn’t have to move it tractor to tractor. The new F9p had new firmware and was different to set up than my old one and I hadn’t done it right. Fixed that and presto, works good ever since.:grinning:

1 Like

1.30?

@PotatoFarmer , Far left column of the popup from speed. FUZ 0, GPS 573 (just fired it up hasn’t moved.) IMU 189.9 10 ~ (low # 9 - 13)

GGA & VTG signals @Bwatts just the 2 signals,

Ok, I guess you’ll need one of the many smarter people than me out there to help.:wink:

One thing to be sure is to create the field with the real antenna not in simulator far away.
Big easting/northing numbers can also make it slow and bumpy.
You can see theses numbers in the data tab I think.

The fields I have been in were made 2 or 3 years ago.

I think I found it. My CMPS had gone on the blink, I thought It was bricked but there was a post a few days ago with a link to code to calibrate and I figured I had nothing to loose. It came back to life. I had the filter set to 80% IMU forever. I now set it to 20% IMU and seems to work. There must have been something it that calibration code or the process got rid of some factory default. I’ll be able to test it more in the next few days.

What are you guys running for a IMU-GPS fusion?

Oh and thanks for the help!!

Had a similar issue, the tractor would be far behind the actual position. Activating the steering took a long time till it quit. Ended up replacing the PCB box, haven’t had a minute to open it up to see what’s going on inside. Not sure how the arduino on the PCB can mess with the GPS position since they are not connceted but that fixed it for me. I’ll report back when I find some time to hunt down the bugs in that controller box.

Been running 60 IMU - 40 GPS, seems to work.