SNIP issue

I have a problem with SNIP. Each time SNIP restarts, it returns to the default settings, i.e., connections from the Serial Streams tab and Pushed-Out Streams tab are lost and 3 (default) connections appear on the Relay Streams tab.
So every time SNIP starts, I have to clear the Relay Streams tab and manually add the necessary connections to the Serial Streams tab and Pushed-Out Streams tab again. Very annoying.
This problem appeared a few months ago. Previously, my own connections were saved and were used automatically when the program started. On my other SNIP computer, when the program starts, the connections remain as they should.
I have tried versions wLITE2.09 and wLITE2.12.
Can anyone advise how to get my own connections back up automatically?

Have you checked Auto Start in the following tabs: “Caster and Clients”, “Serial Streams” and “Pushed-Out Streams”?
Just a thought, I haven’t had that problem.

I think SNIP should remember all settings irrespectively of auto-start settings.

Did not find anything from the use-snip support pages, perhaps a question there would help?

Auto start is checked in serial streams and pushed-out streams. But not in Casters and Clients since I’m not using SNIP as a caster.

Probably, but I can’t find a discussion forum where to ask.

Seems they now prefer questions by email:

1 Like

Somehow I solved this issue. I uninstalled SNIP and removed all SNIP-files that I could find. Installed again and run SNIP as administrator. Now my streams are saved and automatically loaded at startup.

1 Like

I don’t know much about windows but I did not find where SNIP saves settings. Nothing from registry, nothing from program files or program data. Perhaps the program did not have access rights to some folders to save data but got it when installed with admin rights?

Yes I think the trick is just to run snip with admins rights.

I believe the root problem here was that SNIP was not able to write files where it expected so, hence the setting were no retained the next time it ran. We have seen this occur in some Win10 installations where file writes were disabled. In recent editions of SNIP we test for this occurring at start. A careful reading of the console log will likely show an entry to this effect.

The SNIP NTRIP Caster writes its settings to the file simpleNTRIP.ini for the user account that it is running under (at C:\Users<user>\AppData\Roaming\SCSC). Please resist editing that. That user does not need to be an admin, but is does need to have file write privileges. It also writes various log files alongside the /bin folder where the executable (simpleNTRIP.exe) is found. If you are interested in the details see this link: Backing up your SNIP deployment - SNIP Support

Regards, DCKelley, SNIP support team

1 Like