Ucenter issues

I just received my f9p, antenna and wifi ntrip master. I downloaded ucenter on my fzg1 and try to run it and get a couple errors.

“The code execution cannot proceed because MSVCR120.dll was not found. Reinstalling the program may fix this problem”

Same thing withMSVCR140.dll

I tried reinstalling but same result. Anyone have any ideas?

I tried installing on my laptop and it installed properly. Only thing here is when I plug the f9p into USB my laptop doesn’t recognize it plugged in. No idea why

It may have recognized F9p as a sensor in the system devices section.

Ok go into the location shown, most likely it exists but has a little different name.

See how the highlighted one has _clr0400 tacked on. Copy and paste it, then delete the junk off the end of the copied one. Restart and you should be good.

It may have some other junk tacked on the end depending how updated .net service is. Just find the one that starts with “msvcr120”

Also update your C++ distributable too.

1 Like

If none of the above works, check you have installed the right version of u-centre.

Ive had the msvcr120.dll pop up on my laptop, and all tablets. Its pretty common at least for me. Not sure about the other one though.

I’m sure that I had this and it was down to me using the 64bit version (on a 64bit machine). Installed the 32bit version and it worked.

1 Like

It doesn’t recognize it as a sensor. It’s listed under comm 5.

1 Like

It’s doesn’t show it as ublox device either

Yes I’m downloading v22.05

Did you finally get u center installed?

No didn’t. I downloaded the whole visual studio last night. I uninstalled and reinstalled u center. I did get myself down to only the one error upon startup of ucenter which was the one you tried helping me with.

I did what you said but still didn’t get rid of that error.

I tried renaming that file again but it won’t let me

Can I download it from somewhere instead?

Try this…


That did it! Thanks. Went through the whole list but this is the one that worked!


The older version 20 does not seem to require the .dll, version 22 does. Sorry I sent you to the wrong file, was able to replicate and repair this issue on my machine the .dll is in the syWOW64 file. (on the tablets was in system32)

1 Like