5.7.2 Release

We keep trying!

Fixes for Stanley guidance, and minor updates to AOG.

AgIO has a lot of changes including UDP Monitor, Serial Monitor, lots of internal changes to ntrip connections. The accumulated bytes flashes orange/blue when NTRIP is connected and talking.

Section 8 to 16 finally send. Linux can set the local subnet - not needed for Windows. Shortcut keys fix. Sections can be set to either be completely out of boundary before turning off or touching. Hungarian has been added.

Swap XY on the BNO is a new setting in Steer Settings. If you want to use it you must update the ino with the latest - but only that reason.


Updated to 5.72 and Roll changed to opposite as I used it before.
I do use Y direction and cant get that back easily.

I am trying to make the Swap work:
But without succes from AOG
Other changes from AOG, do go to steer board teensy! (AIO panda system on UDP)

Managed to do the swap by changing roll pitch (only in first two places just below (steerConfig.IsUseY_Axis ) so they are same in Zhandler.

How should the Swap work, are there something special to do in setup before?

Then my roll direction is again Y
pitch = asin(t2) * RAD_TO_DEG_X_10;
roll = atan2(t0, t1) * RAD_TO_DEG_X_10;
pitch = asin(t2) * RAD_TO_DEG_X_10;
roll = atan2(t0, t1) * RAD_TO_DEG_X_10;

Does it not swap on the AIO when yiu change in AOG?

No nothing happens.

Not even if I change the 1 and Zero directly in ino here:
uint8_t IsUseY_Axis = 0; //Set to 0 to use X Axis, 1 to use Y avis

Must admit only tried that once.


Doesn’t your code look like this as opposed to what you posted? @Larsvest

Correct this is how code look like before I change the upper part, to be identical to bottom.

I guessed it could be there, because those lines were just after new line 156 in changes from 5.71 to 5.72 (looking on github)

you didn’t update the ino to latest?

Do you mind trying the latest?

Tried the yesterday upload, and as soon as the ino was loaded the axis changed .
I am not able to make any change to X and Y by changing (and click send) in the picture you see here.

The same problem occur both on this panda board and on my look alike AIO board,

ok thank you, we will investigate. I was sure it worked

If it work on your computer, it could be language related!

A few AIO boards tried, they all worked fine. The GPS only board - that needs to be fixed

1 Like

so the panda board should work as well - but only when using udp.

The AIO has been tested - it works as well - but only if using udp as the steer only works with udp

1 Like

Thank you.
Yes work now :slight_smile:
Not that it matter, but when choosing X in AOG, my roll goes over Y of BNO.
EDIT : which actually is correct. Rolling around the X axis :smiley:

Ya it super confusing so just switch till it works lol. I can never keep it straight