AB line true one way, sways other

Ab line is correct one way but is a few inches off the other way. Using version 6.2 for agopen on a teensy panda

I’ve zeroed the inclinometer a few time. The line is true but the trator dosn’t stay on it 100%

Drive a ab line from a to b then turn around and drive same line from b to a and measure difference then enter that in you antenna offset.

The antenna offset wasn’t the fix…its working great in pure pursuit though… stanley gains was drifting a few inches off now and then

We can see on your picture, that you have overlap one way and a gap the other.
To correct this, you have 2 options! Set the correct antenna offset, or change your WAS center.
To reduce wiggle, you must experiment with proportional gain, and min pwm, and CPD (counts per degree) Check the instruction videos !
More weight or dual wheels on front axcle helped to reduce wiggle on my tractor, when using the 12 m weed harrow in 3 point hitch , as it drags tractor sideways a lot.

3rd option is change IMU 0, to match ab line. If you are sure that antenna is center of tractor and WAS 0 is correct.

While driving back same ab line measure difference between tracks. While stopped change IMU offset until AOG shows distance to line same value as you measured. Then try driving again and see if you tracks overlap as they should.

When using driving back on same ab line method autosteer must drive very good. Or else you cant find whats exact offset is needed.

i would make that line at least 50 meters as it sometimes need a few meters to get steady on the line

What we can see in the picture is that your cross track error (xte) is always green, its always a positive number. Your lines are probably correct, but your tractor is always driving 2-4" to the left of that line. When your worked ground is to the left of the tractor you have an overlap and when your worked ground is to the right of the tractor you have a skip.

You need to re-zero your WAS so that the xte averages 0. In order to do that

Step 1 - pick a point off on the horizon, drive straight towards it, when that point stops drifting sideways, press the zero button.

Step 2 - Turn off Integral in your Stanley/Pure Pursuit Settings

Step 3 - wrench icon → charts → xte chart

Step 4 - Autosteer configuration → make fine adjustments to WAS zero in order to drive the average xte to zero

After you have finished the WAS centering, drive an AB with the XTE average as 0. Now turn around on that same line and drive back the opposite direction on the same line. If the wheel tracks are not perfectly in line then you need to calibrate your IMU or you need to enter a small antenna offset. Make the necessary IMU/offset adjustments, and keep driving a line/back on same line until the wheel tracks are identical.


So turning off intigral has helped, my overlap is now consistent and not sometimes correct and sometimes overlapping… my xte is slightly more on the positive side than negative side.

This can I adjust on the fly with adjusting was zero to the negative side? Also what’s the 10cm stand for on your xte chart where as mine is 80cm

The scale of your graph is +80cm to -80cm. Hit the + to zoom in to something more useful.

Also, always ensure your IMU is oriented correctly with regards to XY, that it’s zeroed for roll on a flat piece of land and it’s inverted or not as required. Any of these incorrect will result in strange offsets.

1 Like

Thanks everyone for the input. The WAS wasn’t dialed in 100% Zeroing in in with the xte chart solved my problems. Thanks again


How far was your zeroing off (WAS Zero values before and after)?

Also, can anyone explain XTE and how one should tune settings properly to get it to zero?