Adding UDP to PCBv2

i speak about the reset switch on nano near the chip

Yes, I have also tried to use that to reset it

can you see the adress ? can you ping it ?

1 Like

Did you use old bootloader for nano? (A choice in arduino ide)

I have tried both, I’ve got a couple different nanos. One of them loads fine with the regular boot loader , and the other one I have used the old boot loader to get it to upload.

After trying several things(I had to fix the common fault on the enc28j60) I can finally see the address show up in the UDP monitor of AGIO. It shows a PGN of <237. It still doesn’t show it as being connected to AGIO though.

Can you ping it from another device on your network?

I am able to ping the usb to ethernet hub that I have set by following the YouTube videos at But I cannot get it to ping the machine control (which I believe is or my panda board ( and my panda board does appear to be connecting to AGIO and working correctly at least on the bench. I’m sorry, I am still wrapping my head around how networks work so I may be missing something simple. I didn’t have much trouble updating my steer board to udp or getting the panda board connected over Udp so I thought this would also go smoothly :joy:

By “hub”, I think you mean switch :slight_smile:

You don’t usually need to configure a switch unless it’s Layer 3 (which most home ones aren’t). That leads me to think you’re referring to a router, what is the make and model of this device?

I think you may have a basic network issue here, something straight forward.

Yes you’re correct, switch would be the right term! It’s just Cable Matters usb-a to 4-port ethernet switch.
Cable Matters USB 3.1 to 4-Port…
I also think your right that is is probably a network issue, I’m just not sure what to try now. I’ve watched the videos on ethernet setup but as you can probably tell I’m no expert :smiley:

You have probably said previously, but what are you doing with this? Plugging this into your laptop via USB and then connecting the PCB to it via Ethernet?

What is handling the routing?

I just have a simple WiFi router for mine, it handles all of the routing, etc. Power that off a 12V battery, connect to PCB with an Ethernet cable and then connect to laptop using WiFi. Works a treat.

You got it, i plug it into my fz-g1 with the usb and then connect to the ethernet

Is the FZ-G1 connected to your WiFi?

Also I noticed you said your panda board has the address It cannot have this address as this if your network broadcast address, no device on your network can use this.

Do you have a network scanner? If not, can you connect everything, then download this ( ) and scan the IP range to, then post the results here (a screenshot works)?

I have tried it with the WiFi turned off as well and still no luck.
Here is what I got from the scan with panda board and machine control both plugged in and Wi-Fi turned off.

It says there were 3 alive hosts the only one not shown here is
Thanks for the help!
This is maybe a dumb question but would the steer board need to be plugged in for the machine control to be found? It has been out in the shop this whole time and I’ve been trying to just get machine connected in my desk…

Can see your desktop, maybe a switch, but little else. If you say that 120 is live, then that’s a total of three devices.

Can’t see you FZ-G1, is it connected to the network?

You need to connect everything to the same network / router. This is where I think you may be going wrong.

What router are you using? Forget the USB hub you have for now, what router are you connecting everything to? Your FZ-G1 tablet, Panda board and PCB should all be connected to the same router.

Will the switch not handle it? The picture was taken on my fz-g1 so the alive 3 would be the switch, the panda board and the tablet I believe? I went and got my steer board and it still connects fine with the switch as well. I will try to steal the ethernet shield from it tonight and try it with the machine code. Maybe all the ethernet shields I have are junk :man_shrugging:

Edit: it doesn’t seem to be the ethernet shield
Edit: it most definitely is the ethernet shields :joy:thanks for the help

Maybe the crossed type/ or not crossed cable was the problem, if your switch does not support Auto MDI-X.

It could be a crossover cable, but that would be unusual.

I may be barking up the wrong tree here, but I’m still not sure how this network is put together.

@gpierce720 can you confirm what @Larsvest is suggesting, but please can you also just clarify your network layout?

  1. Start with the router: is it wired or wireless? What is the local IP address? What is the make and model?
  2. Connect your tablet, can it ping the router?
  3. Connect the PCB with a network cable to the router, do the link lights light up on the PCB network interface?
  4. Can you ping the PCB from your tablet?

Those are your basic network checks.

I am sorry, I think my poor understanding of networks is contributing to the confusion. I hope I am able to sufficiently answer your questions.
I am not using a router. Just a CableMatters usb-a to 4-port ethernet switch (model 202069) plugged directly into my fz-g1. I could not find any documentation on whether it supports auto mdi-x.
I am then directly plugging the switch into my boards (steer, machine, panda) for a wired system.
Now that I am using a enc28j60 that I know works, I am able to find the machine board IP address in the angry IP scanner @bluerabbit showed me(is that the same as a ping? I can also try through command prompt but I’m not worried now that it is connecting to AGIO fine) and the switch has always showed up fine in the scanner. The link lights are working fine as well.

I’m sure I caused further confusion because the link lights have both always showed activity on the enc28j60 and when I would go into the UDP monitor in AGIO I could find the IP address that is associated with the board but it would not connect to AGIO. This made me assume the ethernet shields I was using were fine and it was a network issue.

The ethernet shields did have the common ground fault issue, which I resolved(correctly I think!) but they are still not working. I will stay away from the dk electronics boards from now on unless I find a simple way to fix them.

I did end up going to the machine v_5 as well to get it working instead of v5_6 thanks to help from @Kevin

I hope I am correctly answering your questions but I do thank you all for the help!

1 Like