Adding UDP to PCBv2

Hey guys, I’m trying to move from USB to Ethernet on a PCBv2, have bought a nano shield, plugged it into the board, flashed the nano with the correct sketch, connected to a switch, but it’s not working.

There is power to the nano (mounted on the shield), but the shield Ethernet port link lights are off, it’s like there is no power to the Ethernet port.

If I connect the nano to a laptop via the USB cable, then everything works. As soon as I unplug the USB, it dies.

Powering the board from a 12v battery, there is power to the driver and to the nano, but it’s almost like I’m missing a switch or something to activate the Ethernet shield.

Does anyone have any ideas what I’m missing?


There are lots of Ethernet shields on eBay and Amazon and Ali, that have a faulty trace, theres a youtube video of how to repair them.

Have a search.

I had this problem with a machine board, wasted days trying to find the problem and it just needed a trace removing on the shield.

Think its this video:

Check voltage at the Vin port in both situations. Pcb V2 feed 5 V at the 5V (out) port of nano. Don’t think it go back trough the 5v regulator on the nano.

1 Like

Thanks, am just looking at this now. This could well be the problem. Will confirm shortly.

Just to confirm that it wasn’t a faulty / badly designed shield, it is a voltage problem. 5V pin on the nano is kicking out 2.7V.

Always helps if you plug the board in the right way! I’d assumed the Ethernet port was to the rear of the board, it’s not.

That’s not at all embarrassing…


The simple fix is the best fix.


Was your problem also that the lights on the enc28j60 were off @TeddyStamford? I am trying to piece together a Udp machine board and both lights on the Ethernet module are coming on but I can’t seem to get it to connect to AGio. I will check the continuity as the video shows tomorrow and see but I think I may have a different problem.

The lights were off as the voltage pins were not lined up right. I’m kind of surprised it didn’t blow something.

Have you tried plugging in a USB cable with the Ethernet shield unplugged from the PCB (and the nano mounted)? You should get link LEDs.

I did try that as well and I am getting the link lights, so I’m guessing that probably rules out the faulty traces issue that is common with the ethernet shields?
I’m guessing it is something with my networking I have to figure out…

Have you checked the network address in AgIO? I think it defaults to 192,168.5.x and you are probably on 192.168.1.x.

I have…unfortunately still no luck. I did have a faulty enc28j60 module, and got that fixed last night (I think!)but I’m still not getting a connection. I have had Udp working for both my pcbv2 and my panda board on the same Ethernet adapter/tablet so I think I’ve got to have something wrong with the nano/enc28j60 going on.

Long shot, but have you permitted this traffic through the Window firewall?

I just tried turning off the firewall momentarily to see if that made a difference and nothing seems to have changed. I’m beginning to wonder if I have a bad set of cheap nanos or if I damaged the enc28j60 while trying to fix it. I’ll have to try testing them with something else. Thank you for the suggestion though!

if you can open the serial monitor via USB to see message
he will show IP adress or nothing … or reboot…

1 Like

I should have thought of that :laughing: nothing is showing up in the serial monitor.

normally you need to have this

1 Like

If I load EEPROM read onto it and check the serial monitor I am getting information but when I reload the UDP Machine program, nothing shows up again….

but did you reload with reset switch ?

No, I have just been uploading it again through the arduino ide. I am making a simple beginner mistake? :joy:How do I use the reset switch to upload?