Almost had it working, after crash i cannot enable steering

Kaupoi v4,1 +cytron cd13s + ads1115+ was +steermotor.
No imu. No rtk. All conneted by USB. Forgot something?

Got the system assembled before christmas and started testing in januari. But a computer exchange forced me to shift to v5.7.1 for theboard and 5.7.2 for agio/agopen.

Now i’m frustrated because i can not get the steermotor enabled. At some point the steer motor made a turn when i sended settings to the nano in kaupoi board. But otherwise totally dead exept when activatedby controls on the cytron… No action when i clichh the drive arrows in bosrd setting. Got the was zeroed and the angle displayed. Drive in circle works and adjust pulses per degree.

I can not in any way get the steer motor activated. The tractor direction symol in down right corner remains red. Scrolled back amd forth in settins trying to find what is wrong. But after twoo months , now entering planting season, im frustrated
Please help. What am i missing? Wich are the criteriasfor to get the steering enabled. Tried search here but got drenched in way morre sophisticated issues.

Thanks in advance
B.E.E from Sweden.

Do you have speed reading in ago? If you don’t, the reason might be you have not enabled vtg messages in your f9p config.

I Do not know,but i will check that asap. The GPS symbol in agio is green and connected but i have no idea if it reads speed.
Thank you for answer and ideas to check up.


When you changed versions did you update the ino on the nano?

Update the nano to the version of agopen your using.
Disable acs712 if you have one (current sensor).
Check voltages with multimetar on pwm1 and pwm2 on board.
Check your wiring to steer enable switch if you have one otherwise set the steering enable to none in the menu where you set the motor controller and etc.

Hi. Thanks for advice. I have checked some of your tip. And yes, i have speed reading
I got zero volt at outgoing pwm connectios when i toggle the drive arrows on steering settup page.
I did not check continuity of steerswitch but i have done that recently as well as continuity for pwm connections. Took some pictures. Lets see if i can add them here

Edit: no i dont understand how to add pictures.

Hello, I can try to help with adding pictures! See the button on the far right in my picture below (the one with an upwards arrow). Click that and it will allow you to upload photos!
Button to add pictures on Open Ag

Ok. Then i’m not yet allowed yet (or something) . Because in that place i got just a smiley icon for :crazy_face:

I guess i’m to new on this forum.

I see, that makes sense. I am quite new as well and this really helped me:

Uppdate, long time ago now but i think i solved it by downloading a and installing new firmware in nano.

Thats because you had selected Steer Enable by switch or a button… next time check this