AOG 6,0 on Linux seems to work

Tested the freshly baked Release Release 6.0.0 · farmerbriantee/AgOpenGPS · GitHub
Seems to work in simulator so far…

Plain wine 9,0 install, and added corefonts with winetricks.
Running on Debian 12.


Nice! What happens when the settings button is clicked? I tried this earlier(on a different version), and the program would always crash at that point… Have you tried running AgIO?

Did you install MS DotNet 4.8 with winetricks, @bitfieldfarm?

Everything seems to work. Not tested in real life.

Ah, yes. Sorry. Forgot that.
I was just asked if I would install mono, and pressed yes. Not sure what version it was.
I have a mono-2.0 folder within my wine prefix.

Seems to work…

That’s great that it will work with just the Mono implementation of dotnet in wine.

Were you able to get AgIO to actually function with real UDP connections?

Not able to try that yet. I don’t have my equipment on farm at the moment.
But at least it’s far more easier to test stuff in the office.

How did/do you install wine? My attempts at this(wasn’t the first time), resulted in disabling apt, and an hour of work trying to solve that :roll_eyes:. Got apt fixed, but wine has always been very confusing to me.
There’s winehq, wine, mono, and all kinds of other things that make my life confusing…

Got it working using this.


1 Like

One of the things that prevented AOG from running natively under Mono on Linux was the use of windows path separators, which don’t work on Linux. I discovered, however, that Mono has an environment variable that when set will make the windows paths work on Linux. You can invoke AgOpenGPS like this:

MONO_IOMAP=all mono AgOpenGPS.exe

For some reason AOG under mono puts the AgOpenGPS fields and settings folder in $HOME/AgOpenGPS, rather than in Documents like AOG under wine will do. Can symlink the two locations like this:

ln -s $HOME/Documents/AgOpenGPS $HOME/

I think on Ubuntu you can install mono and winforms with

apt-get install mono-complete

On Arm systems, we would need OpenTK.dll compiled for ARM.

1 Like

Well, on mono, I struggle to ever get AgIO to save the UDP on button. And on wine, it never reads or sends from agio.

Very true. I do remember AgIO not running right before. I’m not actually sure it works right under wine either.

If you have multiple apps running on wine, it’s best to use wineprefix. That way you can have different setups for the apps.

This time I had ChatGPT to help me.
It’s also useful to debug errors.
I just sudo apt install wine, but had to add a repo to get winetricks.

New to me was the WineHQ keys. Did’nt know of that until now.

Summary of my discussion with GPT to get it working:

  1. Add WineHQ APT Repository:
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install software-properties-common
sudo add-apt-repository 'deb bullseye main'
  1. Install WineHQ Keys:
wget -O - | sudo gpg --dearmor -o /usr/share/keyrings/winehq-archive-keyring.gpg
echo 'deb [signed-by=/usr/share/keyrings/winehq-archive-keyring.gpg] bullseye main' | sudo tee /etc/apt/sources.list.d/wine.list > /dev/null
  1. Update APT and Install Wine:
sudo apt-get update
sudo apt-get install --install-recommends winehq-stable
  1. Install Winetricks:
    :thinking: I had som problems getting this so ended up with the commands below. Think this is needed for Debian only. Never had problems installing winetricks on Ubuntu.
sudo apt-get install cabextract
chmod +x winetricks
sudo mv winetricks /usr/local/bin
  1. Use Winetricks to Install Corefonts:
WINEPREFIX=~/aog winetricks corefonts
  1. Check Wine Version:
wine --version
  1. Clean Up Duplicate Repository Entries (if needed): Check and remove duplicate entries in repository files:
sudo nano /etc/apt/sources.list.d/archive_uri-https_dl_winehq_org_wine-builds_debian_-bookworm.list
sudo nano /etc/apt/sources.list.d/wine.list

After removing duplicates, update APT:

sudo apt-get update

This summary should guide you through the Wine installation process on Debian 12. Remember to adapt the commands based on your distribution and system configuration.

I put AgOpenGPS in ~/aog/aog
Standing in the folder I start AOG it with:

WINEPREFIX=~/aog wine "AgOpenGPS.exe"
1 Like

First time I ran AOG I was asked to install the missing stuff. Sadly I pressed enter abit fast, so don’t remember what it asked for. But I think it was Mono.