AOG can't determine the direction of the machine

I have a recently assembled AIO PCB V2.5 standard version (single GPS + IMU [BNO085]), and currently I’m in the initial setting up/testing phase.
The main difference in my setup to an ordinary AIO PCB is that I use an Emlid Reach M+ GPS receiver instead of an F9P GPS module. I completed the steer setup wizzard without any problem, and then I noticed that it does not know which direction the machine is facing (“?” next to the tractor), it changes its position while moving with the machine but not the direction in which the tractor on the screen is facing (e.g., If I go eastward the tractor on the screen drift sideways while facing north). Touching/clicking the tractor to reset the direction does nothing, no matter whether I move or not with the machine.
I have the baud rate changed (“baudGPS” variable to 115200) in the .ino for the Teensy, no other changes.


  1. Using AOG without the AIO PCB and only using the GPS receiver (M+) over wifi: direction detection works immediately.
  2. Reverse detection turned off: nothing changes.
  3. Removing the IMU from the board: still doesn’t work.

Can anybody help me, please? Thank you!

I also have problem of direction .
It manifests when tractor is going and turning slow.

When i go faster and go from the spot faster then no problem.
I use panda and f9p.

@Lloyd - you didn’t create the field in the SIM did you?

Both of you: what version are you on - 5.7.2? Reverse detection is greatly improved in, but no official release as yet. I can post a link to it if you want to try that.

1 Like

Well you have to drive faster than 1.5 km/hr to reset direction.

I use 5.7.2 but if you can give me the link of that version to try…

I’m pretty sure that I didn’t, but I will double check it, then report back.
I’m using 5.7.2, but my problem is not that reverse detection not working, but direction detection in general not working at all.
The link to the newer version would be great.

Edit: I forgot to add that it also doesn’t work when there’s no field created/loaded.

This is the Language branch, built just now, contains all the latest fixes:


So I tried to create a new field while making sure that I’m not in the simulator, still doesn’t work.
I also tried the new version and its behaving the same way: no direction detection at all, no matter which way I go or whether or not I have a field created/loaded. Using the new version and only the M+ GPS receiver direction detection works fine but it doesn’t work with the AIO PCB, just like before with 5.7.2.
It looks like there is no difference between the two versions considering my problem with direction detection.

When you setup the m+ is both gga and vtg enabled?
Are you achieving gps fix?

If you drive forward faster than 2km/h and tap the tractor in the center of the screen to reset direction.

Ive always left direction detection off until the version that is soon to be released. In the new one fix to fix setting are hardcoded to the settings below.


1 Like

Only GGA was enabled, so I enabled VTG and now it looks like it works on the bench. Tomorrow I’m going to try it on the field. Thank you!
I achieved fix btw, and tapping the tractor didn’t make any difference.

I’d like to try I want to use Uturn and 5.7.2 is driving me nuts.

EDIT: I see you posted it lower down. Thanks

Hmm or is it just the language branch. Can’t check from my phone.

Now it works, the problem was that I only had GGA selected from the NMEA message types, intead of both GGA and VTG.
Thank you, PotatoFarmer and andyinv for your help!

GGA and VTG?

I’m having the same problem. I run vegetable farming gear at around 0.5kmph. With sometimes three employees sitting on the back, it can be dangerous to ramp up to 1.5 for it to detect

could try the slowpoke branch. I’ve never used it before. Just heard about it

Yes, but that applies to my setup which is an AOG AIO V2.5 PCB and an Emlid Reach M+ GPS receiver in place of a simpleRTK2B F9P GPS module. So I can’t help if you have a normal setup with F9P.

What does that mean?

Ok so SlowPoke is nonexistant. Github has branches, which are little different versions for specific tasks. SlowNoIMU is now the slow version I guess. But there isn’t a compiled version, which means you might have to compile it yourself.

I have never used any of this, just what ive read

Tested and works from 0.2km/h with slowpoke!

And steers great…

1 Like