AOG freezing with GPS serial to USB


I’m using an emlid reach rs+ as my rover, and when I connect AOG to it over serial to USB, I will get a perfect stream of NMEA for about 1 - 3 minutes and then the whole program will freeze. Have to force closure.

Currently using serial over Bluetooth and that works fine, but I think packets are missing. AOG says 5hz, but the NMEA stream is jerky. Whole seconds will pass without a sentence.

Any ideas of how to diagnose and fix the hard-line serial connection? Already tried resetting com ports and reinstalling FTDI drivers. Also tried a new serial cable. Baud and Hz settings are congruent.

I have seen the same holes in NMEA, it helped to move computer closer to GPS reciever, so my next idea is to put a BT reciever outside cabin (my GPS only have BT and wifi connectivity )

Maybe your hard-line serial would work, if you unpair your BT between GPS and computer or just turn off BT? (to eliminate interference from BT side)

Interesting to know I’m not the only one with BT holes! Do you happen to know if there is a default Baud rate for Bluetooth serial? Emlid doesn’t let you define baud for Bluetooth, but through trial and error I found that 57600 seems to get the most NMEA sentences.

Already tried with no Bluetooth unfortunately, but thanks for the idea.

I use baud 38400, just tried to fiddle with the baud in AOG , and I actually got the freeze with BT as well.
But there is also a bps setting in the windows COM port, it is set to 9600 bps by default! maybe you have to tweak that? on my computer it looks this way for COM1:

Edit: Also check the advanced section about FIFO buffer size!


Be aware bps and baud are not exactly same, I think bps set at same or higher than baud in AOG would be better. StackPath


Thanks very much for this! I was unaware of the windows bps setting. That could explain some of my missing sentences. I’ll tweak that when I’m next out.