AOG hanging due to NTRIP

I had this all working and then I bricked my tablet. (Don’t ask - Ok I’ll tell. I had a sun hood being held onto the tablet holder with Magnets - real good ones.) So my new tablet has come and I’m back to setting things up.

Every time The GGA is sent the computer will hang (for up to a 1.5 mins. I think I had it set as before but must not have.

Here is pic of when it hangs.

Send GGA

Here is my list of Mount points. I know I was using one of the bottom 2 because I set up my f9 to recieve all 3 sat systems,

Mount Point

Here is the mesage that frees it from hanging.


Let me know what other info you might need. Thanks

Did you have turn off firewall or make rules in windows firewall for AoG?

No I haven’t but will do right now and report back. I didn’t have to do that on old one.

Well… it’s still windows and I can do some strange things. Win 10 pro or win 10 home makes a huge difference.
Try turn off firewall and see if it works… if it does, you can add AoG as an exception in the firewall.

1 Like

I don’t know if this is Pro or what, But it’s working like a charm with defender off. You are a wizard!!! Thanks a bunch. Now I’ll read up on rules and set AOG as exception.

I got a rule set and then went to try it. It is hanging again. I’ll try undoing the rule and turning defender off and see where I get. I’ll report back.

It should ask you if it is safe to run as soon as you have a connection, maybe missed that? If ignored it will assume no

I wonder if this was the same issue I was getting, I had huge issues with the NTRIP client in AOG causing AOG to hang randomly when connection was lost / re-establishing, causing all kinds of chaos, I just ended up using strtsvr instead, but might investigate when I have five minutes!

It has never asked if OK to run

I have it tracked down to that it is when it sends GGA - maybe not, I’ll try setting to 0 (turn off).and setting to a lot larger number. I’ll look into strtsv also.

When I search for “strtsv” I get nothing that looks helpful. Typo??

Yes, you both had a typo. Try rtklib strsvr?

Thats what I meant, sorry typed in hurry on my phone! I just use that, with a virtual serial port (as send my corrections via UDP to dual antenna over ethernet) but works a treat so never bothered to investigate further.

Well, it not that crazy that it will hang during gga because it’s trying to send out your gga sentence in a package thru an tcp port. If your firewall blocks that outgoing port, it will hang… without sending gga it’s only receiving data on a tcp port, what maybe could be open for incoming data…

Here is what I have tried.
1 set frequency to 0. I can not see that GGA is ever sent and it doen’t hang.
2 set frequency to 120. I tries to send GGA and it hangs.
3 set incoming and out going exception for all ports. Hangs on sending GGA.

1 2 were both done with firewall turned off.
3 done with firewall turned on.

the port required for my correction provider is 10000. Is this the port I would make an exception for?

You turned off defender and it worked you said a few messages back… does it work with defender off? Or not at all? Can you try set gga interval to 12? That’s the standard value. (With defender off?

Defender off I can Get 2 maybe 3 GGA sends then Hangs. I’ll have to wait until tomorrow to try - my son took the tractor.

I may have found the problem. My tablet is a 2 in 1 with a Micro USB 2.0. So I have to use an OTG adapter. I’m wondering if it isn’t restricting things. I’m searching to find any other problems with solution. I may end up getting a OTC cord rather than the adapter. I’ll report back.

In the tablet mode I have a USB 3 and It’s working fine on that port.

Probably the micro usb is not working good when doing multiple connections or something.

I did speed tests with a thumb drive I had laying around. Not much diff.

Speed tests
micro read = 17.439 MB/S
micro write = 3.857

normal usb read = 17.58
normal usb write = 3.88

I decided not to fight the micro USB tablet and run with the tablet in notebook form (USB 3) avalable. Actually pretty easy to modify the tablet holder into a notebook holder. Thanks for all of your help!!