AOGMatic Servo to control Sprayer Switch ( HardySprayII ou Evrard EC2500)

I watched your video, you obviously have a wiring error on the board or a fault on it. Connecting 5v should not cut the whole circuit I suppose that somewhere 5v and GND are connected. by a wire, a button, etc.

that 3 of the servos work I suppose this is probable if the board is only powered by the arduino.

check the vcc and v+ connections on the pin of the board

this is how its all conected
i took all the led and switches and still only 3 server work

So i have downloaded this code and all servors work (854.1 KB)
maybe thgere is somthig wrong with the code ? i have downloaded twice to see i i saw any diference and still didnt work

Are you using usb or udp code? you modify the line #define WORK_WITHOUT_CONTROL //comment if you want to use the code with switch control ?

usb code

just changed it stin only the first 3 servor
all of the other pin have graund to + 4.97v
ground to signal 383mv but it does not change when the section are opening and closing
but the first 3 do go down to 180mv

tried with:

#define SERVO_MIN 125
#define SERVO_MAX 625
#define SERVO_FREQ 60

nope still the same

the stupidest thing we didn’t even think about it :rofl:. you must define the pins in the dedicated page in aog. assign the function and position on the plate as you wish. in aog by default only the 3rd are defined

I this page ?
If it is I have 7 sections already


pin 1 corresponds to location 0 on the board and so on. :wink:


Yeah all working :smiley:

If in a later stage I want to go udp I just have to re upload the nano and attach it to this Internet shield?

Thanks alot Bricbric and Daniel for the help

@Daniel is the boss !

to switch to udp it’s not more complicated than that! Glad we found the problem. Sometimes it’s not much but we look for a long time. :sweat_smile:


so every thing is in the same place just put them together and update the code for the udp and thats it ?

Yes :wink:.