Arduino COM port issue

Hello, I am setting up the whole system for autosteering and the problem I find is that I upload the sketch to the arduino nano without problems through the COM21, when placing the arduino in the V2 pcb, feed it with 12V and reconnect the arduino to the notebook windows tells me that it is an unknown device, if I connect the arduino without it being on the autosteering board I can connect it to the agopengps software without problems and there is communication between the two since windows keeps showing me the arduino in COM21, someone has an idea of What could be the problem?
P.S. I have tried with two arduino nano boards with the same result

Your PCB has a problem. What happens if you put the nano in the PCB but don’t power it via 12v?

Happens the same, with or without the 12V, I double checked the pcb and the solderings, all seems to be good, so if there are no other suggestion I have to start to tear down every part till I find what’s wrong

take a picture to show to us?

IMG_20201206_090725_314 Here is the picture

we don’t really see the diode under the white wires it seems inverted

The diode is ok, anyhow I’m powering the pcb just from gnd and 12 out, without the relay

Do you have a multimeter, what’s your Nano’s 5v when installed in the PCB powered via usb and standalone?

What happens if you plug in usb, then install the nano into the PCB? Does Windows lose the usb connection?

I don’t have a nano in front of me, does it have a seperate usb to serial chip? If Windows doesn’t recognize the usb device something must be affecting that usb chip.

Clear pictures would help with diagnosis. Underside of the PCB too.

Windows has connection with the nano, I uploaded the sketch with the same notebook, but as you says, when I plug the nano in the pcb it looses the COM Port and turns into unknown device

Have you tested the absence this continuity between the different circuit there are surely welds that touches

1 Like

Soldering issue is most likely IMHO.

I’ll check that and then post the results, thanks

Double check the seating af your nano, looks like it is seated one step too low,
So is 5v pin on nano where 5v comes from pcb?
Edit:
I missed the the picture angle when I made my suggestion.
Good to know that you found a fix for this clone issue.

Yes, I’ve checked all connections and voltages, all are good, now I’ve noticed some Arduino nano clone boards has an issue when are powered externaly with the ftdi chip, give me some minutes to try the fix and I’ll update the thread

Problem solved, the issue is the clone Arduino itself, as the article I read says the chinese are so good to copy the boards that they copyied the bugs too, here the link to the page, hope to help, thanks a lot buddies for your help.
https://ketturi.kapsi.fi/2014/04/how-to-fix-moody-arduino-nano/![IMG_20201206_170133_610|666x500](upload://5ey7faqb6jCJXOf4MNubyFwEapw.jpeg)

2 Likes

The link didn’t want to load for me. Is that picture the fix? How did plugging it into the PCB cause the problem?

Apparently the communication problem occur only when the arduino is already powered before the usb connection or maybe just the pin connected in the board can cause this behaviour.

Not grounded “test” pin
The fix is to solder these two pins

@LBournissen good job :+1:

The solution is as you can see in the picture, just make a bridge between pins 25 and 26.
To me the issues happens no matter if I power up the arduino by USB before or after power up the board, the arduino only worked if I had it unplugged from the board.
Above I pasted what says in the page I found.

Apparently I’m not the only one that have had problems with a Arduino (clone) nano’s USB connection. Usually it works ok but sometimes, particularly when an external power input is used, a FTDI chip inside the Arduino does not want to be detected by computer. This is bug made by the original Arduino developers to their schematics, and can be easily fixed afterwards if there is odd troubles with it.

This fault is due one missing connection. The FTDI FT232’s datasheet says that pin named TEST must be connected to ground, or otherwise it will not work properly.
So why the Arduino group does not have connected that TEST signal to ground? Who knows… Maybe it is a bug, oversight or misconception. FTDI clearly shows how their chip should be connected in multiple cases in their datasheets application notes.
*So if you get these “USB device not recognized” in windows, or if your console fills up with USB error messages in nix systems when connecting the Arduino it is not you, it is the Arduino. If the TEST signal pin is not tied down, it seems that the FTDI FT232 usb-to-serial converter goes in some bizarre testing mode (hence the name for the pin) if it floats up during USB handshake.
Conveniently there is a ground pin just next to the TEST pin. Actually it is an Analog GND, not the same thing as GND, but I measured them to be connected together. Better than nothing even though it may broke some design rules. Usually Digital GND and Analog GND should be separated as much as possible, and only have single short route between them to stop ground loops.
Connecting the TEST signal to the ground fixed all problems that I had with USB. Now the Arduino is detected every single time it is connected to USB device. Even my Android phone now detects and shows FTDI chip. This problem may have gone unnoticed because when the Arduino is powered from the USB port, it usually connects without problem. But if power and ground connections are formed in wrong order, or the Arduino is already powered when the USB connection is made, it is left unrecognized by USB host.

2 Likes

Thanks for this, I was experiencing the problem when the board wasn’t even being powered.