Arduino compile problems

Sorry to bother people with a likely basic problem, but its driving me mad, been trying for hours! I am trying to load Math’s BNO080 code to the arduino, from Github.

However, every time i try to compile it I get an error with the messages as per the screen shot. I have tried uninstalling The Arduino IDE and reinstalling. Google searches mention library issues possibly? Any help gladly received - thank you

The ino file should have a bunch of tabs at the top when ready. I think you probably have to add this or replace a tab on the original 4.3 ino.

Thanks ww i see what you mean.
I guess I’m downloading incorrectly or something as i have tried several times with the same result :roll_eyes:
I’m extracting the files from the github into the original support files folder but when i go to open with the IDE it says it should be in a different folder and offers to do it for me which i do and then it opens as per the screenshot

Ok I just gave it a try. copy the 3 needed files into this folder and then delete the one it supposed to replace then rename folder to match name of ino file and it compiled
bnoino

2 Likes

Thanks ww but i still cant get it to work. The three Autosteer files as in your screen shot with the .ino on them don’t have .ino when i have extracted them from the download from the github.
Do you mean copy them into the original 4.3.10 folder?

The 3 files that have BNO08x in them. Yes copy them into the original folder. When its done it should look just like the list of files above.

1 Like

Thanks I’ll try again :blush:

Maybe your windows setup should be changed, like the file extension problem in the Dual GPS PCB v1. 2 thread where kris found this as a help.

1 Like

Thank you for everybody’s help, I managed it eventually with wwfarms instructions! Eventually got the .ino with the tabs across the top of the page.
Thank you
Paul

After downloading, before unzipping, unlock the zip first

Had big issues compiling today, turns out my IDE was out of date once I updated no problems.

Edit, works with the windows store app version 1.8.49.0 does not work with the standalone version 1.8.15