Arduino Drops after 12v applied

Hi, I’m sure this is posted somewhere on here, can’t seem to find it. I built a PCBv2, Cytron, ADS1115, no mma attached at the moment. Plug in the USB from Nano to computer, works great, all day long. Reads WAS shows shows yellow compass. When I apply the 12v to the board, nano stops transmitting (no TX LED).

Any ideas would he a huge help thanks

You have a chineese nano, with the fdti fault that arduino corrected later. Something with a missing gnd connection

Any visual differences between the Chinese and Arduino original?

I am not sure.
If you can connect 12v before usb it will work fine or cut 5v from usb

There are a simple soldering solution for that fault, but am not able to search for it right now.

I’ve tried it both ways, does the same , applying 12v before usb and after usb.

I’m sorry for the relectuance, I just don’t want to solder it if it doesn’t 100% need it

Now you can check if your nano is like that.

1 Like

It didn’t look quite the same, I looked into the driver a little further and it’s indeed a chinese knock off. I soldered together the pins described in the link you sent. Still acts the same. I tried removing ADS, MMA, and Cytron. Plugged USB into nano, installed on board with no ADS,MMA or Cytron. TX and RX both going and AOG recognizes it. Apply 12V Loses TX. Does the same reversing order of USB and 12v application.

Attach ADS. Same. Attach MMA Same. Attach Cytron Same.

Computer always reads the COM port as “USB Serial CH340” never changes in device manager regardless of TX LED

I did not understand you correctly. When you said works great, all day long, I thought you had it working in a tractor.

But it seems you are on test table.
So if it is a fault, (I have not checked if nano stops blinking at any time) you must first carefully check the PCB ( 5v and 12v at right places and once again all components) then I think you need the on wire to activate relay.
And as far as I remember, the tx should blink no matter if it is powered from PCB only (as soon as nano get 5v it start blinking)
Especially check SDA and SCL (nano A4,A5) lines for soldering flaws.
OR?? Just different gnd between tablet power and PCB power?

Yes sorry, I did not mention I’m table testing. I think you might be onto something with different ground. I’m plugging into my Desktop PC, and have the PCB powered by a car battery near my bench. I don’t have a normal electronics power supply unfortunately.

I restarted the PCB, Applied 12v only. TX starts blinking for approx 9 seconds then stops.
Disconnect 12v, Plug in USB, TX blinks constantly, I assume that’s because it detects the computer.

Not sure what changed last night but it decided to start working. All I really did different was put it on the floor. Everything plugged in, WAS functioning, Cytron Shows output from MA and MB in simulator. I’ll keep running the Sim for a while make sure it’s not a fluke.

Thanks for the help thus far, I really appreciate it!