Arduino sketch issue

Hi guys. I’m having no luck uploading Machine_USB _v5 to an arduino Nano. I’m using IDE 1.8.19. I’ve tried two different boards. I keep getting an error “assign GPIOs was not declared in this scope.” If I try a different sketch, e.g. AOG_Section_control by mtz8302, I get the following error 10 times before it gives up:

An error occurred while uploading the sketch

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x43

Can someone tell me what’s going on? I have successfully uploaded sketches in the past.

Have you selected the correct board type in the arduino IDE?

To compile with the correct GPIOs the bord must be selected.

The upload error could be a result of the wrong (old or new) bootloader on the arduino nano. Select the other one in the line just below.

To burn the “new” bootloader, you will need a second arduino. It is easy, but check the avaliable instructions e.g. on youtube…

Ok thanks. I tried a bit ago selecting different boards, different bootloaders, with no luck. Still GPIO error. I am sure I have the Nano.

are you on windows 11?
i had the same problem on windows 11 then tryed on windows 10 and worked fine

Ok I used a different Nano and used a different sketch I found. Now it works. Thanks