Base station banned

Does anyone know a reason why my base station gets banned on rtk2go. It has happened now for the second time and im worried. This is what they sent me

(an inbound PUSH-In data connection attempt using the Rev1 form)
PUSH-IN disconnected, never sent ANY data AFTER the NTRIP setup string, marked as bad connection .
Suggestion: : Ensure your GNSS is tracking before connecting.

@Stefan98 I have tried it quite a few times the last 2 is because my messages were empty, probably a problem between F9P and my PC, com port hangs or similar.
What hardware do you use in your setup?

Im using an esp32 that has been flashed to be an xbee and a ardusimple simpleRTK2B. Everything workt well i was getting an RTK fix in the field, but two days ago i got the first email that the ip has been banned.

@Stefan98 I have not tried ESP32, use pc and rtklib to send with, so I probably can not help you, but if I do not remember much wrong, the program that is on esp 32 is something ala rtklib, and probably has the weakness that it provides to send to without any guarantee that it will receive correct data from F9P, and may thereby send blank data and you will be banned. Hope there are others who can help you.

Thank you for your help

I think there has been an issue with rtk2go. Mine was banned 3 times one night after being fine for teens of months. When I came to test things I noticed several I have monitored before were also not available. With no changes whatsoever mine is fine again now.

I think Allan is right, can see that almost everyone has been online 1 day and 9 hours, on this page

1 Like

Oh okay then, thank you all for your help.
Does someone know an alternative to rtk2go or even better how can i host my own server. All i know is that i need to do port forwarding on my router, and that i can use for a static adress.

Not sure if I’ve done everything right but when I tried rtk2go, the connection hardly ever was alive for more than a few days. I tried SNIP as an NTRIP server and it seemed worse than my BKG NTRIP server (towards rtk2go). Running my own NTRIP casters in parallel had continuous service since the previous manual shutdown.

All you need is a public IP address and port forwarding to your NTRIP caster. Most often the public IP is not static and then noip is of help but not strictly necessary.

Okay so just put in my static ip adress in the esp32 and port forward the 2101 port and thats it

I run my caster on a £6 per month basic VPS
But I’m running a small network now and selling the signal to a few neighbours. For personal use a home server is adequate.

I tried for days to get a setup working where I could host my own Ntrip caster but could never get access to if from the web. I tried setups like Noip or getting a static IP but just couldn’t figure it out. We are in central Alberta and on Telus smart hubs for our internet. Talked to a couple of techies about doing it over a cell modem but couldn’t figure that either. If someone knows how to do it I would be very interested

Telus hub is not p2p compatible, playstation, xbox, and driving your tractor straight are not compatible. So looking forward to starlink.

Get a cell modem with a firewall. Get a static ip sim from telus, you need a business account for this. Its $50/m.

Then dial back to it, and the port the corrections are at.

Or just get Starlink and a virtual static ip and stop giving telus more money for no service.

Cellular is super handy until they have an outage.

Can’t wait for Starlink, it’s an hour to the south of us and an hour to the north.
Why not here

When I tried starlink they didn’t support port forwarding yet.

I had heard that port forwarding was a no on starlinlk as well

So static sim might be your only bet.

have had a number of challenges with but am pretty sure they are self-inflicted / lack of knowledge, but I also send myself to a static public address so I have an alternative if rtk2go fails, but I have only experienced this once where I have discovered it

1 Like

There are quite a few saying PENDING on rtk2go again now and mine has been banned again. Base is fine as I’m using it direct from snip on a PC.