Base station from 40 miles away?

The nearest base station to me is roughly 40 miles away, what kind of correction am I expecting? I’ve heard of people trying corrections from over 70 miles away with no problems

1 Like

7mm + 1mm/km is the stated accuracy of F9P

40miles = 64km

7mm + (1mm*64km) = 71mm or 2.8" of uncertainty

But the further you get from base the more likely you will not be able to see the same satellites, so there also is more chance of losing fix. We have used it around 50km away, It worked, but it is noticeably not quite as crisp of lines as being 10km away.

I would install a local base.


I used one from 48miles away and it worked fine. I couldn’t notice the difference from a 23 mile station

I might try it just for the sake of it as I’ve already got my receiver configured to receive corrections

Depends on the precision you need I guess. We’ve successfully used a base over 140Km away with a topcon AGI-3 based system. By successfully I mean it held an RTK fix and was epically better than the alternative. EGNOS.

…but as @PotatoFarmer says, install a local base. Basically just the cost of a receiver.

You should install your own basestation.

You got two good options here:

Docs here ( in french, use google translate) and here

The cost off all you need is under 500€

You can cast your signal trough centipede, rtk2go or emlid.

If you want a more out of box solution, go for Emlid M2 ( $499) and a muliband GNSS antenna for 80-100€
PotatoFarmer has a video of Emlid M2 here

For PPP i recommend NRcan’s PPP

1 Like

Not wishing to hijack the thread but I’ve actually just experimented with RTKbase myself but am having issues getting it to work. Usual router access is set but get no mount table or connection despite everything appearing correct.

Web interface etc works and receives position data from the f9p which it set up itself I think.

Playing as my SNIP pc died.

…wondering if i need to use the legacy OS on the pi perhaps.

I was thinking of using an ESP32 as an Ntrip server to cast the corrections from a LEA-4t I have laying around to rtk2go. Anybody had experience?

I use the ESP-XBee software on an esp32 to send to RTK2go. Works flawlessly.

My reason for trying the RTKlib based RPi software is to try to attempt to convert messages for a topcon AGI-3.

I’d like to use a standalone esp32 really for cost saving, think I saw a library that can do it all and connect to rtk2go

Thats what I have done.
The same software works fine.

When you log in over SSH, can you ping outside the LAN?

Not sure what you mean? I can connect to it from outside the LAN but I get no mount points. Port 2101 is open and set to the right IP address. All the web based setup works fine. I’m guessing something is not right with RTKlib.

Tried the legacy OS on the pi but no difference. I also tried sending to RTK2go with it, which was probably a mistake as it earned me a few hours ban. ESP Xbee is working fine as did snip.

I did post a lengthy description on exactly how to do this years ago but can’t find it now.


This is it, and I’ve added back the lost image.