Blue screen on AgopenGPS

Hello everyone,
I need your help to solve a problem. When I connect to my GPS (ardusimplertk2b) I receive data via USB. I receive via UART2 the data GGA, GSV, RMC, GSA, GST and GVT.

is that too much? should I just get the GGA and GVT? Also, when I stop driving in the field I have this blue image that appears:

with a lot of numbers at the top, how can I correct this?
Thank you in advance for your assistance

Have you configured the receiver, and saved the configuration?

Try just GGA and VTG,

What baud is your serial port at? Minimum 38400, best is the highest number that works 460800?

I try Just GGA and VGT on USB. It seem more fast to find the connection but don’t change anything for the blue screen and a lot of number on the upper screen. I work at 38400, will try at 460800 on the tomorrow on the morning.

Yep but I use the configuration file :Rover 1Hz with 4G NTRIP Client (sending NMEA-GGA)
From ardusimple because I use a 4g module on the ardusimple card. Is it my problems? Did y have to use the Aortner configuration file instead of this one ?

could my problem come from vibrations on the tractor cabin? Or is it unrelated

I think that could cause problems. You will want to configure with the 1.32SingleAntennaRover in the Agopengps_Boards folder, and then change UART 2 to use the ntrip module. I don’t know the correct configuration for UART 2 but someone on here will.

I configure with the 1.32SingleAntennaRover and lost my rtk fix. It is probably normal because don’t have correction from the 4g. but it seem to work, i didn’t view blue screen and lot of number since i make that. Just need to find what put in UART 2 to work with my 4g ntrip. someone have any idea ?

Screenshots off Ardusimple’s website. I dont have 4G(yet) so can’t verify that it works. Would be a place to start.

I wrote to ardusimple to tell them about the problem and they are supposed to get back to me with a configuration that might work. when I receive it, I will post it to help someone else in the same situation as me. In fact, the configuration (1.32SingleAntennaRover) only works with GPS corrections obtained from a computer connected to 4g via AOG’s NTRIP. when the GPS corrections are obtained directly from the simplertk2b+4g ntrip master card, the configuration does not work well.

there are probably other posts on the forum that talk about this but I haven’t found them yet.

I found the solution! The problem did not come from the configuration of the ardusimple module, it came from the software itself. In the configuration menu, antenna configuration. You have the choice between double antenna or single antenna. For some unknown reason, my choice was reset to default setting. neither choice was checked. I chose fix antenna, test in the field and everything is back to normal.

for the configuration with a 4g Ntrip master module mounted directly on the simplertk2b here is the correct configuration:
simpleRTK2B_FW132_BT+4G_00.txt (25,0 Ko)

don’t forget to remove all MSG except GGA and VTG in:
-view-message view-UBX-CFG-MSG. select NMEA messages

In my case I also increased the frequency to 10 HZ (100ms) because AOG did not stop the sprinkler sections quickly enough. (when the tractor is stopped, the sections close after 4-5 seconds later) even if they are set to 0.2 seconds in the control section. going
UBX-CFG-RATE- (period measurement) 100ms instead of 1000ms

I hope this can help someone else having the same problem as me.

1 Like