Building Section Control

So I’m trying to use AgOpen for section control. I’m using a relay board to interrupt the signal of our rate controller, (open/closed). Testing with Machine USB 5_6.

Maybe I’m missing something obvious, but i haven’t been able to figure out how to control the relays. Section settings, pin settings??

The section control part of the manual seems a little sparse.


Right now section 2 out of 4 sections is working. But I have no idea why or why not. I’ve tried tinkering with the number of sections, and the sections for the pin number, but so far nothing has made sense to me.

Can someone explain to me why section4 is on pin2, section3 is on pin10, and section2 is on pin1.

On the arduino, pin1 is D13, pin2 is D5, pin10 is D4.

Still trying to figure out Section1

Ok, well disregard that previous post. I kept digging and kept on figuring stuff out.
Came across this post Section control V 5.5 - #4 by KentStuff

The mapping of the pins makes no sense to me but this is what I figured out.
The pin # in the Arduino INO do not match AgOpen pin #. They are all one number out.
Screenshot 2022-06-05 224926

So this is what I eventually ended up with, using D5-D8 on the Arduino

I was scrolling through the INO for the UDP setup, and that looks like its better but still doesn’t quite make sense to me. Looks like I will have to rewire a little bit again once I get UDP going. And maybe someone knows why the pins are set up the way that they are??

I think the reason for the strange numbering of first 4 relays, is they were only not used nano pins on the steer board.
So moving to a section only board keep same numbers, that way first 4 would be same when you expand to more sections.

The first number is 0 zero, that is why one number out :slight_smile:

And when you get to setup UDP, you will notice some pins is taken by ethernet port.
That is why 13 can´t be used for section when doing UDP

I experienced similar problems no matter what pins combination in AOG only one section was working (2/4)

Only thing that worked was going back to Machine usb5_0 ino.