Can only steer straight at low speed

Hello after some time and lots of help i managed to get my pcbv2 in the tractor with a bno085 and f9p base and rover . I was so excited it all seems to work but are unable to steer straight at speeds goes straight at low speed . Ive done a tone of reading again and tried many settings but cannot seem to iron it out . It seems that the lap top is slow or i may have faulty Was im not sure . Once again if someone has had the same problem they may be able to help i am a bit lost again .
thanks chris

I am sure you already have the correct setup for the F9P, so it is running at 10 Hz.
But what is your chart saying when you press the speed icon?(you get the white box here!

At this computer it say 10 ~ 5,1, meaning 10 Hz from F9p and 5,1 milliseconds between frames in AOG.
Last night I noticed mine (F9P connected by bluetooth) suddenly dropped to 4 ~ 8, and steering began snaking at the speed of 9 km/h. I think it was because I just passed my house where tractor computer know the WIFI but was too far away to really connect (computer is on phone hotspot to get Nmea for RTK fix) I couldn´t see any new programs using much CPU power in windows job-list.

The F9p does spit out position at 10 Hz but I have some problems with bluetooth com port, sometimes must change between com speed 19200 and 38400 to get correct connection to F9P.(have not been digging deeper into this problem, as I am going UDP this winter)

Your tractor will do oscillations when F9P messages is coming in at speeds below 6 Hz, and if computer is occupied by som other Windows program, slowing AOG frame time up to over 20 milliseconds between frames.


Another thing is autosteer settings.
Example if proportional is too low, then nothing will happen before it is too late, especially driving faster!

Click ? mark and then the proportional to get that Help info box up.

1 Like

Hello Larsvest
I am not sure if i am running at the 10Hz i will have a look today . I have played around with the proportional and other settings quite a bit you think you have it right but when i increase speed it wanders more i am using exbee with my f9p thanks chris

Thanks i think i have problem solved went to u centre and changed hz to 10 drives heaps better now just need to master uturn and then im finished thanks for your advice

This makes me think you did not use a pre configured setup file for the rover.
Too many messages from F9P can flood AGIO and make AOG slow. Only GGA and VTG is needed. (latest Panda do not even need VTG)
There are setup files for F9P firmware 1.12 , 1.13 and 1.3

Start reading here: Improved konfiguration files for f9p with firmware 1.13 - #126 by clogenson

1 Like