Can't connect pcb

Hi everyone.
I’m kind of dummy with this stuff, but hopefully someone can’t help me figure it out.
I connected my pcb, i think that’s what it’s called, to my computer with an ethernet cable. At first it took me a couple days to get the steering wheel icon to turn green. My tractor icon would stay purple. I read allot on this site and other sites and finally it turned green and my tractor icon turned red, i don’t know what i did finally to get it to work.
Then it quit working and i lost my ethernet connection. I then realized the board on pcb the ethernet connects to a getting hot to the touch.

I’m pointing to it in the Picture.
I can’t see a defect in the board, but not sure what to do. Here are some other pics, i learn better with pics sometimes.

I would really appreciate any help one could give.

1 Like

Can you possibly put up a better picture of your pcb. Might give people a better understanding or what version pcb it is
Are you connecting with ethernet and usb cable?
The gps and steer moduie are both showing com ports. Have you enabled ethernet connection in the expanded menu when you click on the blue arrow

I think that’s a PCB from @Aortner. You might get more help contacting him

It is from @Aortner

Do i need to connect both the ethernet and usb cable? I was only connecting the ethernet cable. I didn’t get a usb cable in my kit.
As far as the com port for the steering, i was just clicking on different com ports to see if it would change anything.

The other day it was reading the ethernet connection but then it stopped reading when it started getting hot.

you only need ethernet cable.

the ip of the module is sending from.

Please make your ip fixed of your ethernet adapter to (100 is a example)

best andreas

I thought i did have it on the correct ip address, but it says the ethernet is down. I also noticed it doesn’t light up on the ethernet connection on the module any more. It did have a solid green light and a blinking orange light.

This is the piece that gets hot.
Could this piece be bad?
Should i try different cable?
Just brain storming, I’m a little confused

I checked my ip address.

When i plug my ethernet cable in it tells me that it’s unplugged. I tried a different cable but still the same.

Do i need to do something different, or want would be the next step?

Have you followed the ethernet setup guide from the github wiki. What pcb are you using? Put up a picture

It is one from @Aortner

I have done the github wiki ethernet setup. But at that time it recognized the ethernet cable, now it doesn’t recognize the cable and tells me it’s unplugged even though it is plugged in.

I don’t know anything about that board but sounds like some kind of hardware problem to me. Check and make sure everything is connected correctly and there are no shorts and all the solder joints are good.

I looked at it and i think everything looks fine. I know the piece I circled gets hot to were you don’t want to leave your figure on it to long.

I thought that might have something to do with it?

I zoomed in on you picture and see a few pins that arent soldered. I dont know if they do anything on that setup. You also might check that the voltage going to that module is correct.