Clear Applied Area

The program version 5.6.32 has an unhandled exception when the “Clear Applied Areas” button is clicked. When you click the button and the section is in manual on “Yellow tool” the program throws the following error.


See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
at AgOpenGPS.FormGPS.oglMain_Paint(Object sender, PaintEventArgs e)
at System.Windows.Forms.Control.OnPaint(PaintEventArgs e)
at OpenTK.GLControl.OnPaint(PaintEventArgs e)
at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer)
at System.Windows.Forms.Control.WmPaint(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.UserControl.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Checked in the new 5.7.0 release and this is still a bug.

Seems to work just fine. Not sure why yours does not work

Try v 5.7

I have tried it with 5.7. I will take a video to show you the exact steps. It is also with a field that does not have a boundary if that matters. Basically a blank field.

Here is the video showing the error.

1 Like

find my video of this afternoon that i full recorded the 5.7

my udp cannot work so i reput an usb version for autosteer for this test

And i use my pandabox USB but im not sure is working correctly because never catch speed … i have position roll…

0:50 problem with luminosity but i dont do the modification to avoid this

( 5:00 to 9:00) i think for the CPD and Ackerman it is wrong to ask to use 20° and it is better to request maximun
our was if it is on pivot willbe really follow but if we combined rod the pivot cannot be proportional ( or it is an other request but we need a graph point to set the angle according the sensor position )

By the way this is really good and easy , thanks to make this Wizard

At 12:00 i try to set up the min PWM but the motor never start ( speed ) ? ( normally target for my case 25)
as oposite at 15:00 for max pwm it is not probleme

at 18:00 try to follow a line but impossible tractor drift ( no speed so problem with my gps )

If you turn the wheels too sharp to set CPD, then it is very non linear in many setups. The WAS may not move very much as you get to lock steering so i found it is much worse. But hopefully others can try as well. It is a tricky part of the calibration.

At 12:00 - yes the steer motor should start. Hmmmmm.

The wizard is mostly useful for setting the settings in the right order.

Have others tried it?

1 Like

Make sure the sections are off before deleting. You are telling it to draw sections and delete them at the same time. If the Auto or Manual button are enabled - you can’t delete. I guess i missed checking if someone turned on an individual section.

So the easy answer - Turn off sections before deleting sections

Yep, I knew that was the temporary fix but the unhandled exception is the bug. Sometimes operator error is inevitable. I am good at that software testing feature!

Thanks, Brian for the awesome software!

Yes you are !

I will fix for the inevitable next update.

Thank you!

We had the pre release out asking for bugs to be found for almost 2 months - no one caught this one.