Com connection drops with autosteer

Hello. I have a problem with connection drops it looks like this: . I have tried to disconnect the Targus dell charger from the tablet but it does not help. My setup looks like this: image I use 12v to 24v conventer.

I had set my board up like yours, and had the same problems, with the connection dropping.

I now have a separate power supply from the battery to the 12-24v converter, and ground the 12-24v back to the battery also. I use a relay from the 12v out to trigger the supply.

It works perfectly now, hope this helps.

It does look like you loose connection to the GPS receiver. Aog shows the I’m Lost screen.
Could it be a power issue to the GPS receiver?

I would expect the motor to stop when AoG losses GPS. It looks quite bumpy, maybe USB connections are not so good anymore? It could only be the GPS data losing connection because I would expect if the f9p lost power it would take a few more seconds to recover.

I think you’re right, it’s typical for loose USB connectors.
I screw everything on rigidly.

Do you have separate power for USB-hub? Or do you power it from tablet?

I agree with Lars. I had similar problems and talked to out local computer tech, and he said I need to always use a powered USB hub. He said it’s a common problem.

I think you may have some flaw on the PCB.
Got an original Nano? I used to have problems with cheap fakes and now only use the original. The same is true for sensors and transducer.
Also check the correct installation of capacitors and resistors.

You need to add ground to your relay… 12v out to ground to trigger the relay.
But yes mostly like that

@Seelsy Thank you! Look like the second relay setup works fine, I also cut the 5v from usb cable. I cultivated about 3 hectares and no connection drops. I also put ferrite cores on the power cables. I use normal not active usb hub.

Still haven’t cut the 5v wire to Arduino from the USB Hub, but I have exactly the same symptoms like you have with loosing the connection. (I am using home soldered board with ITB2 motor driver and also have tried with JLC V2 boards). For a moment I thought, there is a fast charger conflict with USB hub as charger use data pins to control the charging speed. it is disconnecting rapidly when charger is plugged, but lagging like yours, when it is off. So I got Lenovo tablet with more specific charging port, but it got even worse :slight_smile: Luckily I could return the tablet to the shop. With exactly same boards, system was working on Dell venue 10 last year (I smashed the tablet and can’t prove), so I have no idea, it is amazing Windows update or Dell update.

Look like the problem appears only when I disconnect charger ( from Dell venue 11 pro (5130) and plug it again (it happens for a moment during tractor startup because of voltage drop). When I disconnect it for longer than ~3 sec and plug in again - connection to autosteer is dropped (I hear windows device disconnect sound) and then random com port freezes happens (not always).
@Gatis What tablet do you use now? Did you solve the problem with connection drops?

I suggest you go and take the config on UCenter. I had the problem too. It’s your receiver that’s saturating. Be sure to keep only the RMC and VTG messages for relief, we don’t need the others. Then you can go back to 8Hz and make sure that the baudrates are set to 115,200. And above all, don’t forget to save at each step. Finally go to the management of Windows peripherals, on the com port of your receiver and set the baudrates to 115,200 there too. From memory it is set to 38,000 from the start. This should be much better, and don’t forget a good quality special data usb cable. Tell me if the problem is solved.

Sorry for my english, i use Google translate

1 Like

This does not apply to della, but to any tablet. It is best to connect the charger with the Autoster PCB so that the ground is branched from one place (the ground of the charger is shared with the USB gnd and hence the problems).

After one year struggle, finally found out the COM connection problem. Never trust anything - USB extender cable (Not home made) from USB hub to tablet didn’t have correct properties. USB flash drives and arduinos worked fine, but when F9 kicked in, data flow was much greater and data was damaged. Most likely it didn’t have proper twisted pair data lines or screening.
Maybe someone find this info useful.

1 Like