COM Port disconnecting in AgIO - but only when stopping or U-turning

Hello! I am new here but have a decent tech background.

I am trying out AgOpenGPS this spring. My approach is to start small and simple and build up piece by piece. At the moment my goal is simply to have a glorified light bar with field painting (so no autosteer yet). My hardware is very basic: MS Surface running AgOpenGPS v 6.0.10 with an AdruSimple F9P connected via USB (at the time of purchase I found posts for USB and didn’t know about the move towards UDP).

My problem is that AgIO frequently (almost always) loses the USB connection to the F9P, when the tractor stops moving for a bit, or frequently when U-turning quickly at the end of a field. I disabled RTK since it was through a spotty phone hotspot connection but the issue kept happening.

To troubleshoot/get going again, I have to disconnect from COM port in AgIO, then in device mangler I disable the com port, and then enable the comm port, then in AgIO reconnect to the comm port and all is okay again until tractor stops moving, or do a U-turn at the end of a field.

It really seems that AgIO is overly aggressive in “sanity” checking the incoming GPS data and sets the COM port to malfunctioning if the GPS data shows the tractor not moving, or changing direction too quickly. Is that possible? Any ideas to get this fixed for more testing with my current hardware? I would like to see this working and find out that accuracy level before committing to getting a PCB board built etc.

Thank you for reading! - Kyle

You probably experienced, the old and well known problems with USB. Often solved with making sure everything have same gnd. A problem could be tablet/computer charger does not have same gnd as PCB. Like having charger in cigarette lighter output in tractor, and PCB direct power from battery.

It sounds like he doesn’t have a steering PCB yet, just f9p plugged into usb. I think it’s likely your usb connections aren’t good. Can you try a different usb port on you tablet or usb cable? How are you charging your tablet? Does it with better without the charger connected?

Yes the setup is just an f9p plugged in by USB so it isn’t an issue of a different ground for a PCB and laptop. Yes I have the MS Surface powered in the tractor (I have tried both powered and not powered) the issue was the same. The Windows power management options are turned off so the Surface doesn’t sleep or pause ports, etc.

I have changed the USB cable at first thinking it was a USB connection thing , but I really don’t think it is a physical USB connection issue, since it is way too consistent when it the issue happens. I can drive in the field with bumps and no issues, but stop to check on the equipment for a minute and then connection to the f9p is lost.

In reading other posts it seems that sometimes “reverse detection” causes issues. I am going to disable that and try it today and see how it goes. I do have problems sometimes after u-turning at the end of a field that it thinks the tractor is backing up on the return pass…

I will update after trying again today with “reverse detection” turned off.

Thank you m_elias and Larvsvest.



Just a follow up here in case it is helpful to anyone else in the future.

So I disabled the “Reverse Detection” feature, but I also had a much more stable GPS signal and I am not sure which one of those two items stopped AgIO from booting the connection to the F9P. Oh and I did one more thing, which was upgraded to version 6.0.3 of AgOpenGPS. So the “fix” could have been any one of those, or maybe a combination of those.

Prior the GPS readings were very inconsistent and moving around (using a basestation from from - spent a bunch of time last night experimenting with SBAS on/off and finding other base stations to use until I had a GPS signal with little deviation.

Used AgOpenGPS today for hours without a hitch and very accurate, so I am super pleased.

Thank you to the all the people here who put effort into this and make it happen!


If you’re using a base station turn off SBAS.

A grateful user… I sometimes wonder if it is worth all the effort.

Hi m_elias, I should have clarified that I was experimenting with and without using RTK, and the SBAS was without the RTK, but thank you for ensure that I knew that.

Hi gameo. Yes the effort is worth it. A big thank you! For every post here there are hundreds (maybe thousands) of other people using and experimenting with AgOpenGPS. Also remember most people post because of a difficulty so it can feel bias towards people with problems, however in reality there are lots of people having success without issues and likely not posting here.