Com ports on usb hub

I have one of these dell latitude toughbooks, with only 2 usb ports, and I need three. I added a 4 port hub. Windows isn’t creating coms and rescanning in IO only produced the same com. I tried with my other laptop, got 3 ports with 3 coms, connected, and then the program froze. Both win10 latest updates. Anyone point me to the right discussion so I can get this solved, or if you have answers. Thanks

Don’t know why your latitude can’t read usb.
But maybe the freeze is same issue as in the old programs, if gps is connected to the wrong com ports.

It does read them but only through 1 com, say com 5, and they all become com 5, and I connect the steer and only option is com 5, even after windows recognizes it.


Maybe try to change the port number manually.

Well, discovered a bigger problem. In device manager, the serial port says it has no driver, and I’ve tried to get windows to look for one, but no luck. Are there specific drivers for the steering module?

If you have a clone:
https://sparks.gogo.co.nz/assets/site/downloads/CH34x_Install_Windows_v3_4.zip
If you have the original nano:
Drivers - FTDI

Thanks! That’s all it was. I should have known it just needed the driver, which apparently should have been automatic by windows.

Hello,

Now i have a question that’s from same thing, can i use a Windows Tablet with one USB-C port connected to a many usb Hub to us 2 or 3 usbs?

Hello, I use a USB hub (4 ports) USB with external power supply. Works very well.

have a 4-port switch working with 2 Ardusimples and BNO085 w/o probs. this should be worst case for AgOpenGPS