Dual antenna problems with communication ESP32, antenna, tablet and AOG

Hello everyone,

I got into AOG a few months ago and everything worked right away on laptop. I use dual antenna with ESP32 and communication via USB. Code of MTZ8302, GitHub - mtz8302/AOG_GPS_ESP32: DUAL or SINGLE GPS bridge between AgOpenGPS an GPS receiver. Works with 2 UBlox to calculate heading+roll. Corrects and filters. ESP32 + Arduino MEGA, the correction signal from SAPOS (Germany).

Unfortunately nothing has worked for a week.
I have already identified two problems:

  1. I got a new tablet and found that the ESP is interfering with the SIM card.

  2. The F9P works when I connect them alone to AOG. All configs renewed, firmware 1.13. When I wire them up and connect them to the ESP, the “GPS FIX” led of both F9P flash at the same time, no data comes. The leds “GPS >XBEE” and “XBEE>GPS” do not blink.

Already tested on several PCs, always the same. Nothing works on the laptop either.
I have uploaded the latest sketch to the ESP32. The ESP32 looks for wifi in the Arduino’s Serial Monitor.

Can it be that the wifi or the AP of the ESP is interfering with the antennas and the SIM card? Can I turn off the wifi and the AP?

Could someone please give me a hint? Thanks very much!

I’m using ESP and SIM card (RTK correction ) together with my Section Control setup, works perfect WIFI and RTK correction via SIM card. I do not use USB!

Did you try a firmware update to ESP?
Is the ESP Antenna(builtIn) located near the SIM Card antenna?

I have now uploaded the code from Jeep1945 (GitHub - Jeep1945/Dualheading-2022). The antennas are working and the ESP is providing GPS to AOG.

However, the SIM card slot is still blocked when connecting AOG and ESP. It can not be activated until disconnecting ESP. The ESP and the tablet are about 30 cm apart.
Correction signal only works via mobile phone hotspot.
Could it be the tablet?

I did not find any official firmware for the ESP (AZ-Delivery ESP32-WROOM-32 Dev Kit C V4).

Update sketch should be included in Adurino IDE - File - Examples - ESP Examples, (I never did it for ESP only for nano IOT). If I remember me correctly MAHAs Webinterface contains also a Update function.

It seems to be an Windows issue. I had a similar problem, to enable LAN-Ethernet & SIM Card together - I try to find the bootmark for the corresponding link.

How To Use WiFi And Ethernet At Same Time In Windows 10 (kapilarya.com)

I think, I did Method 2 – Using Group Policy

Thanks very much!
I will try and give feedback.

Switched to udp and everything works.