Finally got RTK!

Well after a couple weeks of getting PO’d because I couldn’t get an rtk fix, I finally got it! I had configured and updated my f9p but I forgot to configure my wifi ntrip master! Oops. Didn’t realize I had to set it to connect to wifi and to the base station. I thought with my tablet set to wifi and set to the base station, I was good to go! I hope that this post will someday help someone in the same boat starting out.

Anyway, looks like my next step will be to order and build a PCB. Autosteer, here I come!


Ok, jumped the gun, just a tiny bit! I have no problem getting an rtk fix in ucenter. It connects almost immediately everytime I connect now. However, now I cannot get a fix in aog. What happened? LoL. The other day I did get a fix in aog but now it won’t.

Did you shut down ucenter, before starting AOG?

I didn’t close u center but I disconnected both my receiver and unchecked my ntrip client from u center

So you are absolutely sure no other program is using the receiver com port, and you are able to connect to the receiver in Agio.
What is your com port speed set to in Agio?

1 Like

Completely closed u center this time. Same result. I’m on com 4

Do you get the listening and the send GGA here in Agio screen?

1 Like

You must have a different version than me but here’s same page. Which is the comm port speed?

Yes I still use 5.5 in tractor.

You set the com port speed for the Receiver in your post nr. 7

Try 38400 or even 19200

As long as your ntrip is just saying “Waiting”, then you are probably not online, or you have typed wrong ip somewhere.
It should go like this: Waiting (some sec) then authorizing a sec, and listening Ntrip !

It must say listening and send GGA every 10 sec

The counter starts a Zero every time you connect to Base again, would eventually end up in hours :slight_smile:

At my end I see your Base (ACAMP-ROOF) is working. I connect to rtk2go and my computer say it is at this IP:

Did you click “confirm IP” after typing

Ok I switched my speed to 38400 and it immediately went from float to rtk fix. Thanks! Why do you pick one speed over another?

One more thing,
When I click on confirm IP, it doesn’t do anything. It’s stays the same. I’ll change to a different mount and it stays the same as well. That is not my IP shown?

No it is rtk2go in your country.

Speed, well not sure where you get that info.
I think Brian use 19200 in some of the videos. But it also has to do with the Windows way of handling com ports.

I use Bluetooth from receiver to tablet, and I must disconnect and reconnect receiver com an extra time at each start-up of AOG (shifting speed at each reconnect)
Could probably be solved by setting Windows com correct, but soon I will go udp so won’t bother.

As odd as it is came to this thread because I was having issues getting my RTK to fix tonight. Ended up using your caster lol and worked for a while then lost it too. Gonna try the 38000 tomorrow, hopefully work better