GPS Antenna not work, "No GPS"

Hello. I installed AgOpenGPS, and connected my antenna (Beitian, model: BS-708), to laptop, and then set parameters in serial ports and connected. It’s written that GPS port is connected, but also written on screen: “No GPS, I’m lost”. I went outside and there is same problem. When I go to GPS Data then everything is set on 0 (lat, long etc).

Not a lot to go on, but is your baud and everything set correctly? Is it GGA and VTG being sent?

Hello ,
Have you tried your antenna with U-center software to see the settings?

Would u-center show/control the Beitian BS-708 settings, if any?

Anyway, better to check the GPS receiver first with any application. Never tried AOG with a GPS receiver that does not support even EGNOS/WAAS, not sure if it accepts autonomous receiver mode but it should see the NMEA stream anyway.

Yes apparently it is an antenna with a U-blox U7 inside.

1 Like

Thanks everyone who answered, I solved problem, I think problem was in MHz which antenna works in, when I set 1MHz, it just worked. Greetings.

1 Like