GPS refresh speed

Hi all.
I have fixed up a dual motor system similar to Greg,in France,using the same motors from Amazon ( thank you Greg!)
Today I have managed to get out for a first trial, which showed that the motors work pretty well. However I have been trying to set up the actual autosteer settings having watched Brian’s videos several times. I can’t seem to get the tractor to settle on the line however many settings I seem to alter, and eventually realised that the GPS, Roll and IMU are only altering every few seconds, as opposed to continually altering as per Brian’s videos ( which I am assuming will be contributing to the poor/slow response in autosteer). I am hoping that I have some setting wrong somewhere to do with refresh for example. I’m guessing this is a dumb question to you experienced guys, but can somebody help please?

Rikko, what’s your gps source?
And what did it say at the top left of your screen?

Actually unsure what the hz figure next to fix type is?..because mine took a turn yesterday and wouldn’t go over 1.8hz with Dgps, Aog was very jumpy …came out of Aog into u-centre to check settings, all fine…back to Aog 4.9hz? It is actually supposedly set for 10hz!

HI Brofarm,
Its an f9p ardusimple set using the Andreas rover config.


Hopefully you can see a very por picture taken off a video I took which I cant upload as in the wrong format.

The roll , gps and imu only alter every few seconds whereas in Brian’s videos they are changing constantly.

Thank you

My GPS refresh rate also started out at 2 hz, but after setting the F9P up with Andreas’ setup file, it worked flawlessly. And remember to update the .ino file to 8 hz.

I notice it says that you have “GPS single” which means you are not in RTK fix and therefore your steering will be impossible. Also from your screen I notice that your GPS is only giving you 1Hz. That would explain the once a second change in heading etc.

So my recommendation is to do a couple of things.

  1. Double check that you have the correct config file loaded in your F9P you can do this by checking in U-Center under message view UBX>CFG>MSG (I’m doing this from memory, it might be something else). Maybe just re-flash Andreas’ config file.
  1. Make sure that your baudrate matches the one that your config is set up for. And make sure that your Refresh rate is 8Hz, yours is currently set to 10Hz.

The number next to 10Hz on your screen shot is the frame count and that is an indication of how long it takes to draw each frame in AgOpenGPS, 8 is a good number. I would say that anything under 10 is great.


After further investigation, I had GPS & GLONASS selected and a m8t (none rtk mode) only able to do 4hz!

I must try gps only at 10hz and see if it makes any difference to AOG?

Thank you for the comments and advice. I checked the config file as WT suggested and am embarrassed to say it was the wrong one! I reckon I had loaded, using FILE- GNSS, but not done the save in CONFIG afterwards, the first time round. Not got RTK working yet (still trying to work out how to send my data stream to RTK2go - could do with the video help Richard K mentioned he might try and do after Christmas!) (please) ) , but was steering pretty well to say was only on ‘standard’ f9p. However the twin motors got very hot, and am not sure that is going to be the way forward for me, although it is a tidy setup. Guess it is taking too much torque to move the smaller ‘wheel’ within the steering wheel? You guys that are using the phidgets motor - can you turn the steering wheel manually at the ends with the motor still sat on the wheel, or does it not freewheel? I am wanting to use without u- turn (mounted combi-drill).

I’m using the phidgets motor, and it’s quite heavy to turn when not engaged. It’s doable but my guess is that you’d be tired of it.
I’m using snip for ntrip casting to It’s working very well. Maybe I can help you if that’s the way you want to go.

This is strange. I’m also a Phidgets motor with a gear, in my case the motor resistance is hardly noticeable when steering by hand. What I did notice is that when you shortcircuit the two motor wires, the motor is very hard to turn.

Hi Morten. Your offer of help is very gladly received!
Here is where I am up to:
The rover in the tractor is loaded with the ‘Andreas’ config (f9p) and shows a 3D fix when viewing the Ublox software. Whether the Hertz etc. is set right I’m not too sure.
The base station antenna is mounted on a 30 cm steed disc at least at roofline height on a building, in turn on a scaffold pole.
This I have then connected to the f9p receiver in the office below, and in turn via usb to the laptop running Ublox. I then managed to get the receiver to ‘survey in’ for a day and it says in messages that it has an average 78mm position and shows TIME in the box in top right corner, as I believe it should?
On the toolbar at the bottom there is a box which flashes between UBX and NMEA. Not sure if the messages are enabled or not though?
I have registered on RTK2go and have a Mtpoint and password, and have also loaded SNIP and registered there too.
It is at this point that I am a bit stuck. How to get the stream to RTK2go using the easiest route, is the next step I guess?
Then how to access on the tractor? (what to put, where, in Brian’s Ntrip Client)
Can the tractor laptop use my phone as a hotspot (I have plenty of data) to get the information or does it need a dedicated modem? Also does it mean I would lose the RTK when using the phone (for a call) itself?
So many questions!!
Thank you for your patience

Hi rikko

Your setup sounds like mine. I’m also using my phone as a hotspot, and it still works during a call. The data usage is only around 2 MB/hour.
It sounds like your base is as it should be. Close U-center so you can connect to your com port from snip.
In Snip under the Serial Steams tab you set up your stream, my settings are:
Use your mountpoint and the other local settings.
Now go to Pushed-Out Steams tab and set up your stream there as well. My settings are:
Here you use the password you received when registered at rtk2go.
When done and connected, you go to NTRIP Caster Table where you should find your own stream. It comes up pretty fast.
If there’s further comments or questions, let me know.


Thank you very much Morten - I will give it a go tomorrow and let you know how I get on. :slightly_smiling_face:

Oh, I forgot from AOG NTRIP settings, you just put your mountpoint. My settings look like this:
Hope this works for you as well. Or else let me know.

Morning Morten
I have I think set things up correctly now but have got a red banner instead of the green one indicating that things aren’t good! (see photo)
It keeps attempting to connect but obviously short of some information. I am wondering if the RTCM messages aren’t enabled in Ublox. Do I have to do anything with that please?
RTK photo

I’m not sure what’s going on.
If you’ll try my setup for u-center try this file:
base.txt (6.2 KB)
Use the File > GNSS under GNSS Configuration in the tools section.
After that remember to save the configuration.
Under View > message view, find UBX Cfg Cfg and select the following:
Remember to hit send!
Now you won’t see much going on in u-center but it should work. Close u-center and try again in snip.
Let me know if it works, we don’t give up on this :wink:

Also check in the Packet Console if the desired RTCM Messages are appearing

Hi again,
Some success it seems Morten.!
I went into message view and found that RTCM was greyed out and so in CONFIG - MESSAGE I selected and sent individually the rtcm’s listed on the Ardusimple setup page. That set things in motion so the serial banner is now green and the pushout banner is green but still working on it as only says 99.4% connected. The mount is listed now also but there is no format, type or nav listed yet? Guessing / hoping it may when / if the pushout gets to 100%. However it has been trying for a couple of hours now and seems to have really slowed up improving?

Peter - I haven’t checked the packet console yet (in UBLOX ? ) but presume it is now sending these as I explained above?

Thank you, I will see if it reaches 100% later and then it may give the full information in the list, unless you guys have any thoughts please?


PS was thinking that someone with more skills than me could paste the last dozen or so posts in this thread to the Base setup too, as it may help someone else in the future?

1 Like

Hi again
The percentage connected in snip’s Pushed-Out Streams tab is just an indicator of how much of the time you’ve been running snip that you’ve been connected. It doesn’t have anything to do with the messages or the quality of the connection.
If you still don’t see any messages on the rtk2go website, you still have a problem.
I’d just try the configuration file I posted earlier and give it a go, I’m pretty sure it works.

Ok Thanks Morten, I’ll give that a go tomorrow :slightly_smiling_face:

Hi Morten,
Just an update - things are looking good. ! I tried to connect to the Tractor using Ntrip and it said I have an RTK fix! Not sure why suddenly started but im not about to complain.
I tried to load your base config first but couldn’t, as yours is written for older firmware than mine (1.12)
Aim to try some steering trials with it on Saturday so that will be the true test.
Thank you very much for your help :blush:

1 Like