Help for basic robot guidance system

after searching on wiki and fourm for days I still haven’t figured out the problem:
I would like to point out that I have been using agopengps as a visual guide for 2 years with satisfaction, software, GPS in RTK plus CMPS14.
Now I would like to create a small autonomous robot that follows the paths created with agopengps and I am trying to create a “simplified” system with the minimum hardware possible:
notebook connected to mobile internet, AgOpenGPS ver5.8.x, RTK GPS, Arduino Nano, IBT2 and WAS+CMPS14 via ADS1115.
I assembled according to the schematics found in,Misc,PCB,AutoSteerPCBv4_Original ,AutoSteerSchemati in release5.6.34,but I can’t get the motor to move!!!
It would be helpful if someone could help me start from the basics:
Is the above diagram correct for the Nano software? what exactly should I load onto the Arduino Nano?
I connected everything and I see the CMPS14, but I can’t get the motor to move!!!
Obviously in simulation.
Thanks for any help.

Did you select the ibt2 as the motor controller in AOG? Is the motor fully enabled-the little IMU indicator in the bottom right corner of the main screen and the steer engage button both green? If either one isn’t, motor won’t turn

I would dump the cmps and get a BNO

this is the screen I have,
if I manually move the steering on the simulator I get nothing!!!
even if I push the buttons on the auto-driving configuration I get nothing on the engine…

Edit. It is like you are not connected to steer module. Show setup in AgIO

acting on the manual controls I see the wheels turning but the engine connected to the IBT2 shows no signs of life!!!
Below on the left in the screen
self-guiding configuration next to the button with the tractor with the writing PWM:0, should it indicate something when the steering motor operates?

You should press the physical autosteer button/switch.

Just select , where steer enable, “NONE”.

thank you
I solved it was the steer enable button!!!
very kind everyone to help me…
Sorry for the banality, I’ll update you with the results!!!

I agree with you, as I remember having same issue last year working in office with nano and ibt_2. I think I had to connect(short time) steer switch to gnd first time after restart, even with NONE selected.

Now that I have managed to understand and make the autosteer work, I would like help with another problem: I would like to use an economical L298N as a driver for the electric steering motor, I would use it by bridging the two circuits to increase the power.
The problem is that it has another drive logic, different from the Cytron and the IBT2.
I’ve made some attempts but I can only get rotation in one direction.
I don’t know how to program Arduino and I ask you for help.

If you can’t make the necessary changes then I suggest buying a compatible motor driver.

You want to put them in parallel?

yes the L298N can be put in parallel, the current is doubled, obviously with a single motor.

Two transistors are never perfectly matched, one will flow more current than the other and heat up ever so slightly. BJT transistors (the kind used in the L298N) flow more current when the temperature increases. Before you know it one of them is smoking hot and doing all the work while the other is cool and doing nothing.

is permitted in the technical specifications of the L298N. But the problem is how to connect the L298N to the Arduino Nano for forward and reverse rotation direction.

You will have to program one extra nano output, that does the opposite of the DIR output when in cytron mode. But why not just buy an approved item. I have used ibt_2 for 3 years an it is still the same one.
It is very cheap too.

You’re absolutely right, using all the standard hardware would be easier, but I’m curious and passionate about electronics and IT, I’m learning a lot of things from this experience with AgOpenGPS.
I understood what GPS is, RTK correction, how to configure the receiver etc.etc.
Unfortunately I don’t have any knowledge of C programming, so programming Arduino is impossible for me, for now!!!
But it is a goal for the future, given that now everything is made to work with PLCs, PCs, etc. etc.
I have to thank the patience of many enthusiasts who collaborate and help the community and who have the patience to help me.

I solved the problem !!! my Arduino nano was faulty… one of the two PWM outputs didn’t work…
I changed the Nano and now both directions work…

1 Like