Help me pease

Hello, I am a farmer in the north of France, I cultivate cauliflower and potatoes. I discovered this forum that I read that made me want to get started.
Currently I have successfully installed the software as well as the gps configuration as well as the ntrip. It works wonderfully. I would like to thank all the creators of the latter.
Faced with this step, I embarked on the construction of the autoguiding system. So I succeeded in using the mma as a compass, It’s now that it gets complicated, I tried in vain two sketches that of brian and coffeetrac, but there is nothing to do, I can’t not to make the cytron md 13 work. With pcb, without pcb direct connection to pin 3 and 4, tried 5 6 following arduino codes. I ask for your help. Thanking you in advance

Google translation


Pour aider il faut d’autres paramètres

version du logiciel, type de carte et version …

et quelque photos serait un plus

Bonjour fredolatuile,
Let’s try to debug your problem step by step.

  1. Is it an issue with the wiring ? You should make sure that the MD13S is wired to the arduino according to this schematic :
    To sum it up :
    DIR —> pin D4
    PWM —> pin D3
    GND —> GND of Arduino and of power input “-” on the MD13S
  2. Is the sketch on the Arduino properly working ? You should see several numbers in AOG, in the window “Ports Serial”, section “Port de l’autoguidage”, in the bar below “Du port d’autoguidage”.These numbers will appear after you connected the COM port with the Arduino plugged in.
    Capture du 2020-08-20 22-45-50
    I agree with bricbric though, pictures would be nice. Can you also measure the voltage you get at the pin D3 to see if the Arduino is “talking” to the AD13S ,

What version of AoG are you using? Does your Arduino sketch version match your AoG version?

Hello, Thank you for your answers.
I am currently using version 4.3.10 of agopengps. I tried the arduino codes of support files version 4.3.10 then that of coffetrac and there is no change. I have connected pins 3 and 4 as shown in the diagram, I tried to connect them to pins 5 and 6 no change.
on agopengps it is well connected with the numbers as shown in the photos above that is to say 127 … I tested pins 3 and 4 one gives me 5 v l 'other 0.3. I use the simulator to test the whole it is well connected but I have no answers that I click on the navigation arrows ie no electrical changes to the pins.


Hello, I redid the tests and I concluded that agopengps does not give info to the pwm. Are my settings bad?

Version 4.3.10 can ONLY work properly with arduino code for version 4.3.10.
But I think the problem is that you have no switch connected. Steer switch must be closed (or button pressed) before autosteer can start
You can find a diagram in support files and see steer switch is on pin 6/PD6
Also after ver. 4.0 there Must be a WAS (or simple potentiometer) connected, before AOG will activate autosteer.
Edit: As an add to what Valentin writes in next post, it is also possible to get PWM output in SIM, when driving on an A B line and then clicking left or right turn on screen in AOG

Okay, I tried a few things with a nano alone (no PCB). What I saw :

  • You have to shunt D6 (steer) to GND to enable autosteer (green dot at the bottom right of the sceen), as said Larvest
  • If you want to try different gains and see how the PWM output behaves as the WAS input changes, you have to connect the ADS1115 to the I2C and use a potentiometer to change the measure value. Otherwise, you get a constant error value in the “Autoguidage” window (mine was very high).
  • You can use the “High Max PWM” to change the PWM output as long as the Gain is not set to 0. That way, you can make sure that the PWM works well
  • Also, if I remember well, it’s good practice to configure the Arduino at least once when it was just flashed. Do this from the window “Configuration des modules” with the gear button “Envoyer au module”

That all sounds about right.

hello, i tried a lot of things already without success, i am even starting to despair lol. I managed to get the green dot on agopengps Then tried to change the pmw max but still no response. A question comes to mind. Is it impossible to make agopengps work without a d s 1115?

As I understand it, since V4 yes, it is impossible. You can’t use the internal 10bits ADC anymore, so you’ll have to source an ADS1115 board to use AOG.
What I tried to explain above is how you can test the PWM output without ADS1115, but it’s not supposed to work that way.

Ok I understand better now, I have an ads1115 but I don’t have the angle sensor can I do tests without the angle sensor?

Yes, no problem. If the analog input of the ADS is floating, you will get erratic measurements though.
You can use a simple potentiometer plugged between 5V and GND, the objective is just to have a variable input voltage between 0V and 5V to try the setup (at least if the converter is used in single mode, not differential).
If you still have issues, send pictures or videos, maybe we will notice something else

just to add some comment to Valentin

if you havent potentiometer you can use two resistor to simulate( chose similar and you get the neutral directly

also basic question did you try to push the switch of the cytron to see it it work manually

Hello, bricbricque I pressed manually and the cytron works it makes the motor turn from one direction to another by pressing the buttons. I don’t understand too much for resistances, could you describe yourself a little more please?

au niveau de ton capteur was
branche une resitance entre le +5V et le High
branche une autre resistance* entre le High et le Ground

*de preference la meme genre 300 ohm ou plus
si tu peux faire des photos de ton montage ca aide pour t’aider a te trouver des reponses

You need a WAS signal connected to an ADS otherwise you won’t get any PWM