Help with RTK

Micro v4.5 board. AOG v6.0.10 Aio v5.7
I am having no luck getting RTK fix… ntrip is working but my f9p light stays red. I used the AOG configurator to flash and configure the f9p…with just the f9p on the board and 12 volts applied. The teensy was configured directly with the micro usb.

I am sure i have left something undone.

Everyone seems to be busy. I’m no expert. I’m a programmer and I do everything in a spartan way.

Yeah definitely the wrong time of the year to be asking questions. I am at a loss. I have downloaded U-center. I am looking at it like a monkey doing a math problem. lol

Or you have done too much. You have both USB and UDP going, so where will the ntrip messages go? Check one more time the wiki, especially point nr 6 ! Home · farmerbriantee/AgOpenGPS Wiki · GitHub

Okay i went back and looked. I am getting my ntrip data over wifi (at the moment or hotspot when in the tractor). I dont have a machine board so my computer is going through a usb to network cable adapter to the all in one. I assumed this is UDP should it be serial?

Your GGA & VTG messages are empty, is your f9p antenna outdoors?

Is your antenna outside for the rover outside? I rearly get a float or fix with my antenna sitting by a window, incase your not outside…

yes it is outside unobstructed view

Did you solder the Ethernet header on your teensy? There should be an orange light flashing on the teensy.

yeah it flashes. I guess the pic was taken perfectly between flashes…I downloaded the latest AOG again goin to start from scratch. I need to check the connections between the f9p and the teensy. thank you for your reply

If it flashes, then you are sure f9p is connected to teensy at correct baud rate.
You should expand the UDP and see at what ip numbers everything is connected. Must be same else ntrip messages might go in wrong direction.
Your USB to ethernet adapter should not be seen as USB port in AgIO

Thats true. We can’t see that. And we don’t know in which network it acts.

That makes sense I’ll look at that.

Making progress I think. Its the first time I have seen the f9p led flash green but it went red. Do I need to make changes under device manager to the usb - ethernet adapter? Im still not seeing any gga or vtg.

So it looks like your Teensy and your ethernet are working. I suspect you’re not getting an the necessary rtcm msgs.

I think there’s supposed to be another 1008 or 1230 msg? Is this your own base or someone else’s? Has it worked before?

I’m using a Emlid m2 as a base. I used Ntrip checker app and it’s working. Corrections are sent as rtcm3

Okay so to eliminate the Ian to Ethernet adapter I used a laptop and downloaded the aog. I still get the same issue. So I reprogrammed my teensy because I got this error the first time I did it. Would this have any effect on it.

That is not it either.

You can always use teensyloader.exe to upload hex.

Whats with F9P config? Upload again rover config to it. Not familiar with this tool, but with ucenter its important to save configuration. Or it will revert to previous.

Okay. Its my base station for NTRIP. I used pointonenav and rtk2go and both give me rtk float. So I will look and see what i can do to get my M2 to work…