How to configure u-blox ZED-F9P via command line interface without using u-center? I don't want to rely on u-center software

I have a C099-F9P application board which has a ZED-F9P module. I want to configure ZED-F9P module via command line interface as my project can’t rely on u-center every time to configure it. I tried connecting this module’s UART1 to CP2102(USB to ttl) and accessed it through Docklight serial terminal.

I picked up the hex codes from u-center generation 9 configuration and tried sending it through terminal to UART1, it was able to send it but ZED-F9P is not applying it.

If someone know how to do it please walkthrough me through the process.
Thank you.

1 Like

Check out the source code for Config-o-matric on GitHub. The app is used to configure F9P without U-center.

I don’t know what your reasons for avoiding ucenter are… If you’re a Linux fan, you could look into pygpsclient. It’s GUI based, but makes a nice alternative to ucenter

I’m not familiar with your board specifically but I programmed my base station in Ardiuno IDE, definitely was my favorite option. U-center just confused me and could never get it to work.


Did you programmed it like this?

uint8_t ubx_cfg_valset_uart1_38400_ram[] = { 0xb5,0x62,0x06,0x8a,0x0c,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x52,0x40,0x00,0x96,0x00,0x00,0xc6,0x1f };

Serial1.write(ubx_cfg_valset_uart1_38400_ram, sizeof(ubx_cfg_valset_uart1_38400_ram));

@Davidwedel Thanks, I’ll look into pygpsclient.

@chri5k I am not able to find Config-o-matric, I searched it everywhere.

1 Like

I just found this. Might try to figure it out sometime. If someone else does, I’d love to hear what you did.