How to install rate control firmware on a nano

I had the same error message. That message comes up because you are missing libraries needed to install the firmware. Did you download the whole rate control master folder? My first attempt I didn’t understand the GitHub website, so I just downloaded the rate control hex file and tried to load it and got the same message. If you download the rate control master folder, it will come zipped. Right click on it and select extract all. On my computer I had to unzip it every time in restarted the computer. Once it’s unzipped you should be able to go in and find the rate control firmware in the nano folder. Once everything is unzipped the firmware will appear as a link to Arduino IDE. When you click on it will open the arduino IDE. The rate control firmware will be in the window along with all the libraries needed to install the firmware. You just need to select the comm port and load.

Do you have the ethernet shield removed when uploading the firmware? Using the hex file or PCBsetup no libraries are needed. Setup video:
Setup (1.9 MB)

So, an update on my problems. I tried a few more times with no luck. Finaly got fed up and ordered new nanos from a different source on amazon. The new nanos uploaded software the first try. I did a blank file with the IDE and then uploaded the rate controller software with the update tool. The serial monitor looked just like the one in your video, so I am assuming everything uploaded correctly.

Also is there a Nano pinout? I’m only looking to input a pulse signal from my Krohn flow meter to display gallons an acre.

Also, Thanks for all the help!

Schematics are here:

Usually pin D3 is for the input pulse signal.

The version of the AOG_RC files I downloaded didn’t have that folder. That helps out a lot lol. Thanks again!