How to install rate control firmware on a nano

Could someone please give me a brief run down of how to download the firmware for rate control for nano from GitHub and how to load it on a nano? I am apparently doing something wrong. Thanks!

This app can install the firmware:

Thank you for the link. I was able to get the nano programmed. I am trying to connect the rate controller to the rate control app. Does the rate controller use the same IP address as the aio board (192.168.5)? Is there another step besides setting the IP address on the app?

The rate controller uses the same ip as the steering module. For the rate module the ip has to be sent to it with the upload button in the centre of the screen.

I thought I had successfully installed the firmware on the nano, but it appears I didn’t get it on there. Could you please clarify what exactly I have to install off of GitHub? The first page under modules>nano shows a folder and these two files. Is one of these files what I need?

If I open the folder there is this series of files. Do I need to put those all in a folder for the Arduino IDE to compile?

If you would like to use the Arduino IDE instead of PCBsetup you can go to this page: GitHub - SK21/AOG_RC: AgOpenGPS rate control. Click on the code button and download the zip file. Unzip it and go to the RCNano folder. From there you can start the arduino ide with the file RCnano.ino. You may need to install some libraries.

I hate to keep coming back with questions. I have been messing with this, but I can’t get the rate control module to connect to the rate control app. I downloaded the rate control master from GitHub. I tried to load firmware with arduino ide. I did load firmware with your module loader. (I think it’s on there) I deleted and reinstalled the rate control app from the master. I must have had an older version of the app before. The new app I loaded had the drop down menu to select which module you were using. I tried to get the module connected by sending the ip address under the module tab. I checked my firewall settings on my computer. Everything agopen and rate control is set to allow. The Ethernet switch I am using has two lights per port, one lights at 10 mbps data speed and the other lights at 100 mbps data speed. The computer and aio board both communicate at 100 mbps, the rate control module only shows 10 Mbps at the switch. I am thinking I am still having issues with the nano (tried two different ones, both genuine Arduino) Woulf you have any ideas what else I should try? Thank you

Try this video. You may need to change to the old bootloader. You might not need to remove the ethernet shield.
2024-02-27 (1.7 MB)

Thank you for the video. I did finally get the firmware loaded on the nano. I loaded a blank sketch with arduino ide to clear the nano, then I was able to use you pcb set up app. I have data on the serial monitor for the first time. I still cannot get connected to the rate control app. I have attached a picture of the serial monitor and it says “no serial data” Any ideas what I should try? Thanks

Serial data is disabled when ethernet is connected since ethernet is the preferred way to communicate. If ethernet is disconnected it will send serial data. Is the app on the same subnet? Is the product set to module 0?

I did just try it with the Ethernet cable disconnected, I was able to connect to the rate control app via a usb cable to the nano. On the serial monitor it shows the nano trying to start with IP The rate control app is showing a local IP Is that mismatch an issue, or is that saying the app has an address if .10 on the network and the nano has an address of .50 on the network?

Yes it shows they are on the same subnet, each with its own address. For a serial connection it doesn’t matter about the subnet. This is only for an ethernet connection.

I’m having a little trouble uploading software to a nano board. I have the board hooked up to a tablet. I have serial communication but when I go to upload firmware it gets halfway done and then comes up with a sync error. I tried using the old bootloader also with the same outcome. I watched your video that you posted, and I’ve done everything you did. @SK21

I did have success with mine after I opened Aduino IDE and just loaded a blank sketch on the nano. Then I was able to use the PCB loader to program. If there is a program on your nano already that could be an issue.

I couldn’t get Ethernet working for my system. I tried the nano and Ethernet shield with just section control and it still didn’t work. I went on Amazon and bought a different enc28j60 Ethernet card that is a wired connection and got that to work with section control, so I think the Ethernet shields I got for the nano are junk. I have another Ethernet shield on the way from a different manufacturer to try.

Is it the right com port? Disconnect the nano and check which com port was removed.

Yes. that was the only port where it would connect and give me both green lights. I cycled thru all of them trying to upload the files but they all did the same thing.

I tried to upload thru Arduino tonight. at first it would error out right away. restarted my computer and now it tries to load for a minute or two then gives me a whole bunch of errors.

Download the previous version of IDE… that version you have is no good.

Thanks for the previous version, Hman! I was able to restart my computer and get IDE to upload one file and one file only before having to restart my computer to upload another file lol.

I must be doing something wrong as i am still having trouble with both the IDE and the upload tool. I have uploaded the blank file to both of my nano boards. I then tried to just use the IDE to upload the RCnano.ino file but it won’t even verify so I can upload it.

I then tried the PCB update tool and was having the same problems as before. Port 8 seemed to be the only port I could get any activity in the Serial Monitor page. I tried a few times to upload the Nano rate firmware. Would get half way done and it would show the sync error message. I tried the “regular” boot loader and also the “Use old bootloader”

Have you installed the missing libraries?
Also, are you closing serial monitor in agio before trying IDE, or vise versa. The comm port can only be used by one application at a time.