iPhone hotspot IP issue

I have Getac tablets I have set it to allow multiple connections and I can get NTRIP over my home router. I can also sometimes get NTRIP from my iPhone in SIMulator mode however when I plug in the UDP I loose NTRIP. when I click verify IP for caster it verifies but when I click find mount point it says invalid port. If I put a sim card im it works. Anyone have light on this issue?

Hello David,

I also used the hotspot function of my iPhone in the beginning, and actually had little to no problems with it in the field. I now have a strong router 11 meters above the ground and I now have 100% coverage up to about 500 meters from this. , (otherwise the signal is there but starting to weaken) and that is more than sufficient for me

you may need to connect the laptop to your phone first before starting up agio and agopen

good luck! :wink:

It seems to be when it connects with ipV6, but I’m still testing. My daughters SE works fine and my 12 used to now it doesn’t. Like I said I can get internet on a browser just not in Agopen. One place I noticed that it was coming from subnet instead of 24 bit.

Or maybe that’s called no subnet :man_shrugging:

I had a few issues getting iPhone hotspot to work with my Getac’s as well, but all my problems and solutions don’t seem to match yours. I think your issues stem from Windows prioritizing an ethernet connection for internet over wifi, and I believe there is a registry fix for that. I haven’t done the registry fix but if you search “registry” here in discourse you will likely find it.

Regardless, here’s what I did, maybe one of them helps.

  • On the iPhone hotspot settings, turn on maximize compatibility. This will run the hotspot in 2.4 GHz instead of 5 GHz. I don’t remember if maybe my Getac doesn’t have 5 GHz, but I always have more luck with 2.4 GHz on things that need a reliable connection like my 3d printer, 2d printer, streaming stick, etc.

  • On the new iOS versions the iPhone will automatically set the SSID as the phone’s Name and the settings will force you to use a hotspot password. On older iOS versions this was not so, you could choose an SSID and choose to use no password. If you have the older version then use an SSID without special characters or spaces, and do not leave the password blank. Its probably best to update to the latest version.

Other notes.

  • If you want to use a SIM card inside the tablet then you will likely have to configure the windows APN settings for it to work. Each carrier has a different APN address. I don’t recall exactly where to enter the address, but I’m sure a quick google search will get you on the right path.

  • If you have the correct drivers then you can use the iPhone as a tethered USB connection - the phone will show up as a network device when plugged in. The easiest way to install the correct drivers is to install iTunes, afterwards you can remove iTunes (and retain the drivers) if you don’t want iTunes installed.

I usually run the USB connection. Its a nice reliable connection. Your phone is always plugged in and charging. To make it even easier, I put a USB port on the front of my tablet dock where it is easily seen/in reach, and I mounted a phone holder near to the tablet. I leave the hotspot on anyways and for some reason sometimes it runs over hotspot even though its plugged in. Idk, I receive NTRIP :man_shrugging:

Hey thanks for the info.

A SIM with RogersAT&T seems to work out of box. I’ll keep your SIM suggestions in mind for future frustrations :hot_face:

I have the network connections (allow multiple) configured. (I think this setting is effective because the browser works, I think it is AGOPEN that can’t find where the internet coming from) This worked last season but suddenly quit on my phone (iPhone 12). My daughters SE still works.

Haven’t tried the cable but I’m sure it will work.