iPhone keeps dropping hotspot

I’m using an iPhone hotspot to connect to a Getac tablet. The hotspot works for a few minutes but then will drop and AGOpen loses rtk corrections. Opening the iPhone to the hotspot screen seems to get the iPhone to eventually restart acting as a hotspot.

Is there a setting to keep the iPhone from cutting out?

Is it possible your provider doesn’t allow hotspot ussage with your plan? I know many don’t but am not sure how they go about enforcing it.

My plan (with Telus) claims that it allows hotspot. Does anyone else use them?

Does your phone recognize that a hotspot device is connected? Otherwise it might time out after a few minutes

I haven’t noticed anywhere to list devices on my hotspot screen. Should it list connected devices in settings somewhere?

The tablet lists my phone as it’s connection.

I don’t have a solution for you other than that a wired hotspot seems to be trouble free for me, while wifi hotspot always has issues. Just need a USB cable.

I can’t help you there… I have an Android. But I know a few devices my phone won’t show they’re connected, and shuts off mobile hotspot after 20 minutes. Very annoying

Just plugging the phone into the tablet usb port or is this using a different device for a hotspot?

Most reliable way, download itunes on the tablet to get the iphone drivers. Then just plug in the phone and your done, no messing around.

I had the same issue with Wifi, the fix for me was to listen to internet radio on bluetooth headphones. The additional data usage would keep the phone from stopping data. It was an iphone 8.


Download itunes on the tablet, then when plugging the iphone it create an “Ethernet port” with internet, very nice solution.


It’s been awhile since I looked into this so I might have my stuff mixed up, but there’s been a known issue for years on iPhones where the wifi hotspot will only stay connected if you turn the “Display>Auto-lock” setting to “never”. Something with the auto lock timer. Again, if I remember correctly. As mentioned, download iTunes and connect that way for the best results.

1 Like

I turned the auto-lock to never and that has worked. The constant on screen isn’t great battery-wise but I wasn’t sure how much data I’d go through streaming music.

I’ll try iTunes + plugging the phone into the tablet tomorrow to see how that goes.

This tractor has so many cables running around it now. :crazy_face:

This is the best, plus your phones is always charged.

I think you can manually shut the screen off, just can’t have it auto magically turn off by itself. Because Apple…:face_with_raised_eyebrow:

I don’t mean to brag, but my cheap shit android phone just works.


For about 6 months lol.

Old thread… but try adding a family member to your i cloud and turning on family sharing and compatibility mode.

Had a new install this fall complaining about Hotspot dropping out. Had the phone plugged in, would drop easy during our training trip, plugged in my phone no issues but noticed the phone was not charging.

Changed the charging cable and the hotspot worked flawlessly on both phones.

1 Like