Is my RTK working?

Hi everyone,

I am currently trying to use two ZED-F9P for RTK corrections.

I already installed the base, configured it with the file given by Ardusimple -srtk2b_base_FW_HPG112.txt) and am sending messages through

On the other hand, I also configured my rover with the Ardusimple file srtk2b_rover_FW_HPG112.txt.
AOG successfully recieves NTRIP messages, but I don’t know if they are proprerly transferred to the rover. My config :

I don’t know either if corrections are computed by the rover. Because the “NO RTK” LED didn’t change state on the Ardusimple board (it is solid lit), I’d say it’s actually the opposit. Moreover, when I equip my 50 cm long tractor with a 10 cm wide tool, I get a lot of drift :
Dérive GPS

What did I miss? How can I find what isn’t working?

Good night!

Your setup in Agopen looks right,

  1. Do you have your base antenna outside with a clear sky view?
  2. looks like it is sending out other than rtcm signals, have you turned off NMEA?
  3. Is it set up to do “surve in” so that it can send RTCM 1005?
    search F9P or base setup here in forum.

Hi @pniels,
Thank you for your answer.
My base antenna has not a perfect view of the sky, but it’s outside on a ground plane at the bottom of my roof, so it should be enough. It’s not its final position though
You were right : my base sends lods of NMEA messages, and no RTCM messages. That’s odd, beacuse I used the Ardusimple conf files (Configuration Files - ArduSimple) which are supposed to work fine for base and rover. Am I wrong ?
Anyway, I turned off manually all NMEA messages using U-center > Generation 9 Advanced configuration view. I also turned on all RTCM3 messages.
Now, I get a RTK fix (SUCCESS!). The “NO RTK” LED on the rover module is also completely shut down.
I think I still need to increase the refresh rate. I think 8 Hz or10 Hz are popular choices.
A few question though :

  1. I calculated my base station position with 1 cm accuracy using PPP treatment on the NRCAN website (Precise Point Positioning). Now, what should I do with this data ? Am I supposed to hard code it in the F9P base module to allow it to send it through NTRIP ? Or should I put it in the F9P rover module instead ? Or maybe in AOG ? I dunno… :thinking: it doesn’t seem necessary to get a RTK fix
  2. What RTCM messages is it usefull to broadcast ? The 1005 (enabled by Survey In) is obviously necessary, but what about the others ? (RTCM messages output available on the F9P according to U-centre : 1005, 1074, 1077, 1084, 1087, 1094, 1097, 1124, 1127, 1230, 4072_1, 4072_2)
  3. Also, at what rate should I send them to rtk2go ? 0.1Hz seemed ok to me, but maybe it isn’t.
    Thanks for your help !

1.image base fixed mode time mode 3
2 i use 1005 1077 1087 1097 1127 1230, find it difficult to get a clear answer which ones are the right ones
3 This area I think we need others to answer, thinks 1005 should be sent with 1 hz and the rest with 10, if you send too much data to rtk2go you will be blocked, ie no more rtcm than necessary and no more frequent than necessary.
Hope you can use my advised answer

1 Like

1005 0.1 Hz is plenty. MSM7’s (1077etc) 1Hz. Basically MSM7’s send more data but are a bit more accurate than MSM4’s (1074 etc).

1 Like

Thanks for your answers guys, that’s really helpfull.

Something I didn’t get befort and that I just understood now : RTCM3 protocol is used to transfer corrections from the base station to the rover through NTRIP (server (Rpi/Arduino/ESPrtk) / caster (rtk2go servers) / client (AOG)). Then, NMEA protocol is used to send back corrected position using GGA messages from the rover to AOG through serial. In fact, BOTH RTCM3 and NMEA are used in the whole system, while I thought there was a “good” protocol to choose and a “bad” one to avoid. I leave this explanation here for people as lost as i am (or was).

Anyway, now RTK2GO displays precisely the coordinated I computed, so that’s satisfying. @pniels my interface did look quite different than yours though :

I think I will go with the same messages as you. According to @Alan.Webb, you use MSM7 messages, which are more accurate, so I’ll go with them.

I also use refresh rates of 1 Hz for MSM7 messages, and 0.1 Hz for 1005 message, as recommended. Toriem detailed in another thread how to set messages rates in U-center (What RTCM3.x messages are people using? - #2 by torriem)

Again, thank you verry much for your help

1 Like

@Valentin F9 → UBX → CFG → Tmode3

Hello, can somebody help me with finding out what is not good in config of my base witch i have launched yesterday.
For base station config i have used a config file from ardusimple page, u-blox have latest firmware (1.13)
At the beginning i have made it to survey in for 24 hours and today i set it to fixed mode with coordinates it have calculated (accuracy 0,07m). Yesterday i saw it sends 1005 protocol and others too, today it doesnt send 1005 any more. Where can be a problem? It started snowing here at night, can it be a problem for it?
Where i can find how to set correct frequencies for protocols.

EDIT: i have Ardusimple board at base. And Led with NO RTK is lit all the time.

Hi @Kestutis
From what I can see on RTK2GO, you have the 1005 message send, one every 6 seconds. So it looks good to me. Did you solve the problem somehow ?

The precision of the coordinates you input when you set the F9P to fix mode are not critical to get a RTK fix on the rover. They are critical however to get the precise coordinates of your fields in case you want to change / move the base station, or if you want to share it with someone else in the vicinity. To get accurate results, you may want to use the GNSS correction service provided by your country. In the US, you have CORS stations all over the country, from which you can perform differential GNSS computation. I don’t know if there is an easy to use tool provided. In France, there is an online tool.

Finally, the NO RTK led is lit because the base station F9P doesn’t perform RTK calculations, it only provides RTCM messages. Once your setup will be complete and you have an RTK fix, the NO FIX LED of the rover (not the base) should turn off.

1 Like

Hi @Valentin,
Thank You for an answer. I havent done anything from a beginning and now i see that F9P sends 1005 (1). That is very unexpected. Why it is changing all the time?
Another thing is that if i check my mount point at NTRIP Caster Table
(mount point kalveliuukis) and press map button, it show my base station on google maps, but position from real base is like 100 meters away. Is it normal, or calculations are not good. My base station will be permanent.

The message rate isn’t supposed to change over time, unless you re-configure the F9P with another configuration file or manually in U-center. It is set by the CFG-MSGOUT-RTCM-3XTYPE1005_USB :
This value sets how many seconds elapse between two sending of the message. You can safely send it once every 5 or even 10 seconds, the rover only needs to receive it once to compute a RTK FIX. The other messages though should be sent once per second.

When I did the survey in on the f9p, I think the position was fairly close on the map (no more than a meter or two). I know where your error comes from. When I look at the coordinates given in the 1005, i get this :
When I use the link you gave and clock on "map, I get that :
The coordinates are truncated to 2 digits after the decimal point, hence the big error on the map.
Anyway, even if the position looks correct on google maps, you can’t know for sure if you’re precise at 2 cm. You should use a differential GNSS post-processing method (as suggested above) to get your exact position in your official GNSS positioning system. Useful links :

Hi @Valentin
I do apreciate your time. i think survey in made coordinates preaty close to real possition. And it wouldnt make any difference for all system.
As far as i can understand, my base and all system works.