Kaupoi V4.1 + BNO08x Question

Hi everyone,

I have been trying to bench-test my Kaupoi board today, and have run into issues with the IMU not appearing to be recognised. I was hoping it might be something simple I have missed perhaps?

Board is Kaupoi Mod V4.1
Cytron MD13S
Arduino Nano via UDP
I am running AOG v5.7.1, and have flashed the latest “Autosteer_UDP_v571.ino” onto the arduino

If I plug the arduino in via USB I can get the serial monitor to recognise the IMU, however there is still no pitch/roll/yaw data displayed whether I try UDP or serial.

As in the photo you can see AOG is recognising the steer module via UDP just fine, but no IMU

Thanks in advance for any help! Hopefully just a dumb mistake, but I can’t seem to work it out :sweat_smile:

I have this behaivor with V5.2, If I select and load a vehicle the roll and compass will work, try it out.

1 Like

Try to go trough the whole wizard in steer/tractor setup.
There might be one setting that doesn’t come over automatically.
Pniels had problem to zero the roll, ( roll didn’t show at all) he solved it by doing the wizard.

1 Like

Thank you, I think I had to select and load a vehicle, as the IMU functions now. I also ran the steer wizard to double check!

Despite that it is now functioning, the IMU does not show up as green on AgIO, is this normal behavior?

I have seen that as well. I don’t think it is normal, happened after an update to 5.7 UDP.
Updated to 5.71 so thought it was related to the ino.
Haven’t been able to recreate the problem, but have seen another user mention same problem.
So maybe it is about the upstart of the bno instead.