Nano stops responding


I am having an issue where my nano board connects and can be configured for a short period of time before reverting to “Waiting for AgOpenGps” and nothing I have tried after that point will cause the nano to re-connect properly.

Tried restarting software and computer with no success.

Any advice?


I am having the same issue on one of my units. Changed nano, reflashed, changed cable, I can see I am sending the sketch as lights on nano flicker. But no return info to AOG???

Crazy, I’m having similar problems with one unit.
The other day I was driving down the road and the steer motor started spinning, I didn’t have a cumputer connected.

When I opened the box the cytron had the Mb light on with no computer plugged in… When I plugged the USB into the computer the cytron would stop and go to “neutral”. When I try to manually change steer motor direction seems to work fine.

I plugged in and tried to connect to the nano on the pcb v2 and it wouldn’t send info.

I reflashed the nano witch seemed to work but still nothing in AOG.

New usb Cable didn’t help.

It is an original arduino Nano. I have a cheap one I’m going to try and flash and see it that will communicate.

V4. 3.10

Thanks for the insight so far, updated from 4.3.10 to 5.1.3 today and a similar thing seems to be happening. I think something is causing the nano to hang somehow. When I plugged a different laptop into the nano to update the firmware the steering motor activated almost like it trying to execute a command from last time it was on.

My best guess at this point is making too many settings updates to the nano is problematic in some way. I allow what should be enough time for settings to be updated and the first few usually take but after that nothing I try seems to have any effect.

Will try a different nano shortly.

I am thoroughly confused at this point.

Any advice would be appreciated.


I am currently trouble shooting my problem and it seems I must have a problem with the pcb it’s self. The nano works until I plug it in the pcb. I’m guessing there is either a ground problem, shorting problem.

I think this little black thing is what throw everything off.
Looks like it burnt out?


Another user had a problem with the nano it worked out of PCB but froze when in. Reason was solder paste, Not cleaned away, it made short between i2c lines on PCB