Network NTRIP issues on UDP

Not really a software issue but it is NTRIP related. I seem to be dealing with an IP conflict some where. It only shows up in the UPD Panda boards. I’m using a Getac tough book with an ethernet port. On first go with the .5 subnet I couldn’t get NTRIP at all by changing to the same .1 as my home router I could get NTRIP and GPS. BUT! guess what my home router doesn’t cover 30kms. When I connect my iphone to the tablet with the lan plugged in it just shows no internet and the box periodically loose connection to AGIO. Anyone experienced this or have some wisdom for me?

Try disconnecting the Ethernet cable with your phone connected with agio open. Leave it for a few seconds. Then plug the cable back in. We have issues with(it seems like) agio looking by default on the wired network for Internet, and unplugging the cable forces it to look elsewhere. Just why this happens, I don’t know

Had similar problems on all our Getac F110 tablets. If you are using ethernet and WiFi you can prioritize WiFi over ethernet.

The problem we had was using sim-card in tablet and using cellular connection from the tablet.
Smart sw engineers from Microsoft have decided that cellular connection will be disconnected if there is any other network connected to the machine, even if there is no access to the internet.

We had to make register modification to ignore all non routable networks and then remove the gateway from ethernet IPv4 settings.

Add new dword “IgnoreNonRoutableEthernet” to "HKEY_LOCAL_MACHINE\Software\Microsoft\Wcmsvc

1 Like

Thanks for the suggestion I’ll give it a try. In the past I haven’t had great luck with editing the registry files, but if it’s working for you it should work here. Is yours windows 10?

I had a similar problem, to enable LAN-Ethernet & SIM Card together

How To Use WiFi And Ethernet At Same Time In Windows 10 (kapilarya.com)

I think, I did Method 2 – Using Group Policy

Yes Win 10 professional

Of all weird things if I give it a static IP and gateway on the hotspot it allows me to verify the caster but still says “not connecting to caster”

Are you on Android or IPhone?

We are not using mobile hotspot and WiFi but we use the tablet own cellular connection.

For our use the register edit works well.
Should work for WiFi as well just remove the gateway from the ethernet IPv4 settings.

Also make backup from current registry before make any changes.