No commands going to hydraulic valve

Hi all,

My System:

IH 826 tractor
Baraki open center Hydraulic valve
standard V4.2 all in one board
FZ-G1 tablet
mostly working with V5.8.1 software, although i tried V6.0.10 also with no change

My Problem: In a field, on an ab line, When i click the steering wheel in the bottom right corner of AgOpenGps to enable autosteer, it makes its sound and turns green but i dont get any signals going to my hydraulic valve. no power out on the ampseal lock pin, (hence no power to hydraulic lock valves). Also, no power to the right and left steering valves.

If i power the lock valves manually, (jumper on my relay) the valves lock well, and if i push the MA and MB buttons on the Cytron the R and L valves also activate and turn the wheels nicely (about 3 seconds travel time full R to L) So my hydraulic valve must be working properly.

This is my first time working around any kind of autosteer, am i missing somthing?

thanks for the help!

it seems another person has had this same problem with their cytron not getting any commands. His problem was a tiny little solder bridge on the teensy headers installed by JLCPCB. I checked mine and did not find any. checked my teensy and also did not find anything. I swapped to a different all in one board and have the same problem.

I assume that the lock command sent to ampseal pin 7 originates from the teensy? anyone know what teensy pin it comes from?

In this situation you must also drive faster than 1 kmh. Else use the drive function in the expanded steer window. The red tractor you see must be green, else there will be no pwm

Did you read the wiki and manual?

thanks for the reply!

I know i tried it driving faster than the minimum speed, and i think i tried it with that little tractor clicked green, but i will go out and verify.

Could you post a picture like this where you have 3 green ?
(The third green is the one to right of mentioned purple) post 466 maybe 467.

I finished tracing some wires and my steer switch also does not work. i am switching it to ground with a pushbutton. a light on the all in 1 board lights up when switch is pressed, but the tablet does not react.

my compass is always red, i dont know if i have ever seen it green. (except when it was momentarly working)

i switched to the 6.0.10 program and played with the steer switch and pressure sensor settings and it would suddenly and seemingly randomly react to my steerswitch. lock and R\L baraki valves also worked when steerswitch worked. now they stopped working again.

would a bad pressure switch do this? i tried unplugging it and made no difference. When i first hooked up my baraki valve i did have my P and T lines backwards for a few minutes.

it was really exciting to see those wheels move a little!!

Change to switch. And AOG will change every time you press switch down and release.
Button mean push one time and it stay down, push one more time and it come up

Move the slider to something like 50 % else pressure will turn it off too early.
Hit send after any change in the expanded part of setting window. (make sure PCB is connected when hitting send :slight_smile:

Check the videos.

I THINK IT IS WORKING!!! SO EXCITED!!! THANKS A TON @Larsvest !!! :slight_smile: :slight_smile: :slight_smile:

I changed the pressure setting, that must have been it.
thanks again!!

oh, and for some reason i think it likes v6.0.10 better. pretty sure i played with that pressure setting in v5.8.x and it didnt help. again, THANKYOU!!!

1 Like