No RTK connection, Rover Base setup using RTK2B with Xbee LR and F9P

Hey guys,
I have been stuck for several days trying to get my rover board to connect to my base station via RTK and could use some help from the group. I am fairly certain that I have configured the RTK2B board correctly and that I can see it enter a TIME mode after 120 seconds as anticipated, my guess is that my issue is in the XBee LR transferring and receiving of packets. I’ll try to go into as much detail as possible with what I have done up until this point so you all can see what I have already tried. To be clear, this isn’t an NTrip setup, I have a base station created with an RTK2B board with a XBee LR radio and a F9P GPS receiver, powered off a portable battery supply. On my AOG board I have an F9P GPS receiver and an another XBee LR radio.

To start, I can say that AOG is successfully transmitting data to the tablet. My auto steer, Ethernet, steering angle sensor, and F9P on the board are all functional and working correctly. I have tried update the firmware of the F(P with the AOGConfigOMatic program and using the included config file, however this yielded no results so ultimately I flashed back to just the updated firmware.

So far on the Base station I have connected the board to my laptop, opened UCenter and completed the following.

  1. Updated the firmware to 1.31
  2. Configured the board using the ArduSimpleRTK2B 1.32 Base config file
  3. In UBX-Config I have made the following changes
    -TMODE3" Survey In, 120 seconds, 20 meters

-Rates: 1000ms measurement time on all, 1 cycle nav rate
- Messages: UART1 & UART2 on RTCM 1005,1074,1077, 1084, 1094, 1097, 1127, & 1230

So far on the AOG F9P I have the following:
Fix Mode: 3D
In UBX-Config-Ports

I have made sure to hit send after each change and save config at each session

Outcome thus far
After 120 seconds Fix Mode on Ucenter switches from 3D/DGNSS to TIME/DGNSS
On RTK Board: Solid light for No RTK, flashing lights for GPS fix and GPS to XBEE
On AOG board F9P( indicator light continues to light red for no RTK, and main RTK indicator light is either out or red depending on different configurations of F9P on the board.

Let me know what you guys think I am missing!

You are sending a strange mix of constellation data and both gen 4 & gen 7 rtcm msgs. Try turning off either all ending in 4 or all ending in 7. 107x is GPS (USA sats), 108x is GLO (Russian Glonass), 109x GAL (European Galileo) & 112x BDS (Chinese BeiDou). So use either all xxx4 or all xxx7 along with 1006/1008/1033/1230.

Which PCB are you using? An AIO? Is your Rover Xbee setup to send the data to the Teensy or direct to the F9P (based on the RTL Dest jumpers)? If you’re sending to the Teensy then you likely have a baud mismatch as the stock firmware is set for 9600 baud but your Xbee will most likely be 115200. If you’re sending direct to the F9P then you also likely have a baud mismatch there too as the F9P is running at 460800. Personally I would try to change the firmware so that the Teensy runs at 115200. (359.8 KB)

Start with that and see what happens

Appreciate the reply. I am using an AIO Micro 4.1 Board. I went ahead and made the changes you recommended to the base station. All gen 7 rtcm messages are now off. and the base is broadcasting at 115200. I took your file and reflashed my teensy. Previously it was running on the 460800 baud. Plugging into my F9P on the AOG board my ports now looks like this

Fix in ucenter is showing “3D”, the F9P light is still red however the main middle indicator light for RTK(previously Red) is now off

Not sure if the data is going to the teensy or the F9P… I assumed the F9P

How’s you PCB setup for sending RTK data from the Xbee? Direct to F9P or to Teensy?

Your base’s rtcm msgs are setup to output to uart2 and uart2 is setup for rtcm3 output? The base f9p’s gps->xbee led should be flashing from those msgs. If turn them off the LED should stop flashing.

If your rover f9p’s xbee->GPS led is not flashing then it’s not receiving which means either the xbees aren’t talking or the base’s uart2 output is incorrect.

Once your rover’s f9p shows incoming xbee data on the LED then you can also enable it’s ubx-rxm-rtcm msg on USB and see what rtcm it’s receiving in u-center msg view.

This is currently what the base is outputting. GPS-Xbee is flashing on base station

The AOG Micro board is showing a red light on the F9P for no RTK data, on inspection I believe the Xbee defaults to the Teensy.

Do you just need to change the RTKBaudrate to 115200 up where the variable is declared or need to change it elsewhere in the code?


I am also having some RTK issues on the two systems I built. I’.m also using the v4.1 micro board. I made those changes last night to the teensy and now I’m getting some interesting feed back. I’m not sure if i fixed it or there is a glitch occurring, and my phone was dead so i wasn’t able to get pictures. On my first tractor, I updated teensy with that baud correction, and then plugged the board back into the tractor. The small led in between the FP9 and xbee went from red to red flashing then green indicating rtk, but the larger 5mm indicator led on the front of the board never changed from red. In the AOG software the it was also indicating that it had RTK Fix so i thought perhaps i was good. I wanted to test it and unplugged the radio antenna and it still kept the RTK fix icon and i didn’t see the age counter starting counting beyond 3 to 5 seconds. I went into the other tractor that i didn’t update the teensy on yet and it only indicated GPS single on the AOG software, so i went and updated it’s teensy as well, and it behaved the exact same way. It started indicating RTK in AOG, as well as having the small led on the board light green, but the big 5mm one stayed red. I’m not sure if that means i’m good, and there is something wrong with the 5mm on both of my v4.1 boards or it is thinking it is getting RTK when it really isn’t. I haven’t tried unplugging my base station yet, I thought to do that tonight.

The F9P can hold onto the latest base station data (rtcm) and show RTK for up to 254 seconds (60s in the official config) so you’d either have to wait that long or power cycle the F9P after unplugging the Xbee. I think if AOG is showing RTK that means the F9P has RTK.

What GPS setup are you using?

//Status LED's
#define GGAReceivedLED 13         //Teensy onboard LED
#define Power_on_LED 5            //Red
#define Ethernet_Active_LED 6     //Green
#define GPSRED_LED 9              //Red (Flashing = NO IMU or Dual, ON = GPS fix with IMU)
#define GPSGREEN_LED 10           //Green (Flashing = Dual bad, ON = Dual good)
#define AUTOSTEER_ACTIVE_LED 12   //Green

That’s the bi-color LED description in the firmware. Solid RED sounds fine for single GPS.

I do find the colors a little confusing too but that’s how it is in this firmware.

Of course it is pouring rain tonight, so not going to pull the tractor out to experiment like I planned. Here is what i have in the build so far. I’m using AOG 5.7.2 for the software, as well as all the firmware that came with that build. FP9 firmware is 1.32 and the configuration file is the exact one in the AOG zip file. For the teensy 4.1 I modified the baud rate for the xbee to the 115000 like mentioned above. I am using a all in one 4.1 micro board, same as Crumb23, as he build his on one of the 5 i got from JLCPCB. Im using xbee from Ardusimple LR i think in this build for both tractors.

Before re-flashing the teensy i got no RTK response or indication on the board or within AOG software. After flashing i’m getting RTK green light indicated where the screwdriver is pointing in this photo:

forgive me for using one of my spare boards on the bench to demonstrate vrs the configured one, trying to avoid getting drenched.

This led is staying red no matter what the other one is doing.

It is indicating RTK in this corner on the actual display in the tractor.

and also saying quality RTK in this screen on the actual tractor display.

All that being said, does that mean I am actually getting RTK, and something is just glitching with the LED in photo 2, or does it just think it is getting RTK when it in reality isn’t.

Is there some additional test I can perform?

I gather you’re using single GPS antenna with IMU? According the the code snippet I posted previously solid red means good single GPS with IMU.

Yes, single gps with an IMU. I’m going to try and get the tractor out today and see if I can get some photos of what is happening on the actual board.

According to what you’re describing, you have RTK. The F9P’s led shows solid green, AgOpenGPS shows RTK andn the PCB’s solid red means single GPS with IMU.

1 Like

@m_elias does that mean that the middle led is not supposed to turn green when there is an RTK fix? I might just be misunderstanding what it is indicating then. I thought the solid red is supposed to go green with RTK.

I got into the tractor today between rain storms. here are some actual photos of what is happening. Hopefully this clears it up. I’m hoping i have RTK because i’m planning to attempt to plant for the first time with it next week. The outer indicator light is red indicating no RTK.

If I slide the board out though, the led indicator by the fp9 is green indicating RTK.

On the display it the software though it is saying RTK in the upper right corner.

So i’m trying to determine if the front plate led is not working right, or if there is something else going on here. I looked at the post you sent me of which pins come off the teensy in the firmware to those front LEDS, and checked continuity between the RTK front green LED and pin 10 header and it is connected.

I think it’s working. The first LED is red when powered and turns green with ethernet connection.

The second uses red for single antenna and green for dual antenna.

The third shows Autosteer status.

1 Like

Thank you. For some reason, and i don’t know why i had it in my head that led was supposed to indicate RTK. It looks like I’m good to go. You always help me out on all my endeavors, I’m very thankful!

it was the PCB label i think that was throwing me off. That led is labeled GPS/RTK.

No i need to figure out what i’m going to do for my farther spotty coverage fields. From my research if i build a mobile base station, and get some coverage from my house one they can interfere with each other, so i might look into building some xbee repeaters with the boards you mailed me.