No signal from WAS

Hi I’m trying to get autosteer set up on an articulated sprayer. The WAS appears to be functional and stable but I can’t seem to get an output from the ads1115. We can get a voltage range (0.25V - 4.75V) moving the WAS manually. The steering angle being returned by the autosteer nano is 32326 and I can’t get it to change. The 5/7 steer switch does function.
Autosteer issue

Is this a wiring issue somewhere or a coding issue?


I had an issue similar and it ended up being a bad ADS1115

Same issue here in my first start, new ADS solved for me the problem

Had the same problem, in my case i fried my ads.

Thanks for the feedback I have another ADS board will give it a try hopefully today or tomorrow.

Found a bad connection from ADS, got a reading now, but where I want straight to be it is reading ~-210, which is more than I can adjust from the AOG Steering window. What do I have to change in the .ino to bring this closer to 0?

In the top of the .ino are the instructions:

   *  Wheel angle sensor zero point...
   * 3320 minus 127 = 3193. 1288 counts per 1 volt
   * The 127 (half of 255) is so you can take WAS zero of 3320 
   * from 3193 to 3347. Zero from AOG is sent as a number from 0 to 255. 
   * Leave at 3193 - Only change if using a factory OEM wheel angle Sensor
   * Put your wheels straight forward, adjust WAS physical position
   * So it puts out 2.5v. Do a good installation!
   * Factory WAS - Wheels pointing forward, measure the voltage. 
   * Example 2.2v - So, 2.5 minus 2.2 = 0.3v times 
   * 1288 counts per volt = 386 counts. 3320 - 386 - 127 = 2706.
   * So your new WAS_ZERO is 2706.
  #define WAS_ZERO 3039 

Thanks for all the help so far, I was making progress trying to fine tune the auto steer settings but have found a new problem. The autosteer nano seems to get stuck at “Waiting for AgOpenGPS” pretty frequently. I have tried different ports on the toughbook and sometimes its really slow and sometimes it doesn’t seem to receive the signal to start. Should I try a different USB cable or is this a different issue?

Also when I was trying to dial in the auto steer there seemed to be a significant delay in the motor pulses, what setting should I change to improve this?

I also had an issue with a faulty cheap ADS1115 this week
Wasn’t getting a signal from the WAS and also was causing the Arduino to lock up.
Got a decent adafruit ADS and no problem since.

Thanks for all the feedback, After thoroughly cleaning the soldered connections on the nano and adc it seems to be working much better. I recently noticed that although the WAS is close to centered (~2.8V = 0) each side uses a very different V. With my current settings a max right turn is ~35 degrees, but max left turn is ~-70 degrees. I take it I need to get these closer together before going much further?

Have you adjusted the ackerman?

No, would that setting help with this? The issue seems to be that the WAS has a 2x higher difference turning left compared to right.

I think it should fix that, if the slider has enough adjustment

Does your WAS physically turn further one way?

Probably a dumb question, but have you adjusted your counts per degree? 70 degrees of steer angle seems like a lot

in my case the ads seem to be working as im using a bno055 and it reads fine but the was is a no show, could it still be the ads?

I’m not sure if it physically moves further but it reads like it does. If anything counts per degree is too high currently because the 35 degree right turn angle is too shallow. WAS may not be perfectly centered, will check next time I work on it.

I have adjusted the WAS and it now reads -45 - 35 or so. The current problem I have is the autosteer mostly works at really slow speeds. When I speed up even slightly it begins to wobble back and forth over the AB line with ever increasing severity, even if I start relatively straight on the AB line. The autosteer seems to be reacting very slow with correcting the heading. Any idea what settings I should change for this? Is there to much limitation on the motor? Current settings for the motor are P - 37, Max - 140, Low - 36, Min - 18.